Jump to content
Brian Enos's Forums... Maku mozo!

Recommended Posts

3 hours ago, Superpipe9 said:

Fingers crossed. I sent mine out yesterday 

Mine just left via UPS...

Share this post


Link to post
Share on other sites

I sent two of my three DPP back to leupold for the sliding contact.  I'm not sure if its mentioned in this thread, but i believe the issue is the unit is heating up and melting the sticker they use to hold the contact in place and the recoil is shifting the battery contact back.   I made sure to call and ask about the new board they are putting in the units for the issue.  The guy on the phone told me yes they are replacing the old boards all with new boards.  I received one back today and it has the old board.   =(  I'm supposed to get my other unit back tomorrow and we will see if it has the new board or the old one again.  

Share this post


Link to post
Share on other sites

Has anyone actually seen the "new board"? Mine is going back soon...

Share this post


Link to post
Share on other sites
Posted (edited)

Judging by the pictures in that thread, the new board is like the old board, only the contact is rotated 45 degrees. That means the underlying problem remains, but redneck mitigation I came up will be less effective. Mine is still at Leupold, they estimate it'll take 18 days. Now I'm not sure if I want the return to have the new board.

Edited by lstange
extra word

Share this post


Link to post
Share on other sites

Mine arrived at Leupold on Wednesday, and I just got an email saying it had been shipped back. Guess we'll see...

Share this post


Link to post
Share on other sites

Hello: I just don't get why they can't fix the problem with it. I know people here that have 4 in rotation that are either coming or going to Leupold for repair. I think I would choose a better optic that would hold up better. Some of the guys have gone back to the C-More slide rides since they just seem to work and last. Maybe the SRO or Sig Max3 will be the solution but at those high prices I will be a hold out for a while. Thanks, Eric

Share this post


Link to post
Share on other sites

Mine got to leupold on Wednesday and I got a email today saying one was heading back to me. Fingers crossed they really fixed it

Share this post


Link to post
Share on other sites
2 hours ago, Aircooled6racer said:

I just don't get why they can't fix the problem with it.

There are about 4,000 people shooting Carry Optics. It's a rounding error compared to 10 million hunters.

 

Now if a military or LEO customer complained that would get some attention. But apparently those either don't shoot enough to notice, or are getting different circuit boards.

Share this post


Link to post
Share on other sites

I have 5 DPP and SO FAR none of them have given any issues. Hopefully it stays like that. I'm in the process of replacing all my C-mores.

Share this post


Link to post
Share on other sites

The awake feature quit working on mine and dot brightness started changing on its own, something is rattling inside the unit.  Going to send it back next week. Probably only 1500 rds at the most on this one since new.

Share this post


Link to post
Share on other sites

Cmore coming out with a made in the USA model, will be announced at the shot show in January. Don’t know anything else about it.

Share this post


Link to post
Share on other sites
Posted (edited)

I just recieved an email from a tech at leupold.  I don't know where that other board with the contacts rotated 45 degress came from, but this was the response from leupold.

 

"No, the second-generation orientation of the silver contact is the same but the clear tape over the brass-colored portion extends over and to the end of the green circuit board in the rear, whereas on the first-generation the clear tape is clipped at the edge of the brass-colored portion and does NOT extend over and to the end of the green circuit board in the rear."

 

 

Here are some pictures showing the new version vs the old.  The one on the top is the old style sticker.  The one on the bottom is the new style sticker.

20190820_160844.jpg

20190820_160926.jpg

Edited by arcticfire

Share this post


Link to post
Share on other sites
1 hour ago, arcticfire said:

The one on the bottom is the new style sticker.

So it looks like page 1 of this thread shows the failure of the new style sticker:

And this new style sticker looks exactly like the one that I sent back to Leupold. If so, then the underlying problem still remains.

Share this post


Link to post
Share on other sites
So it looks like page 1 of this thread shows the failure of the new style sticker:
And this new style sticker looks exactly like the one that I sent back to Leupold. If so, then the underlying problem still remains.
Yeah, that definitely looks like the new version.



Sent from my SM-N960U1 using Tapatalk

Share this post


Link to post
Share on other sites
4 hours ago, lstange said:

So it looks like page 1 of this thread shows the failure of the new style sticker:

And this new style sticker looks exactly like the one that I sent back to Leupold. If so, then the underlying problem still remains.

This really sucks to see and means that my brand new DPP that I just sent in for repair after only 700 rounds was the new style and there is no real fix yet. Wonder how long the replacement will last. Bummer. Wonder if they will just give me a refund 

Share this post


Link to post
Share on other sites
Posted (edited)

Mine made it back from Leupold today. The invoice said they replaced the circuit board and cleaned/tested. Mine definitely has the larger sticker that completely covers the copper traces of the board. (like the bottom picture above)  I'll try it out this weekend.

Edited by BillR1

Share this post


Link to post
Share on other sites

My DPP came back from Leupold. Total turnaround time, including shipping, was 25 days. The invoice says "replaced bad circuit board". The new circuit board looks exactly like the one that failed. The central contact is still being held in place by the same sticker, so Leupold has no "fix". Sadly I'm witnessing another example of regression to the mean.

Share this post


Link to post
Share on other sites

What a POS this thing is. I just got mine back and the paper work said they replaced the circuit board however it looks exactly like the one I sent in so no upgrade or fix plus now it’s about 1/3 less bright and it will not blink when you get to full brightness. Complete disappointment. This sucks

Share this post


Link to post
Share on other sites
Posted (edited)

Sign me up for those having issues. I have two Shadow 2s both with Delta Point Pros each, and both have gone bad in a two week period. 

 

At the Oregon State match a couple weeks ago, the first Delta Point had the accelerometer go bad and the sight would not auto turn on. You can hear something rattling inside, and I needed to manually turn it on for every stage.  It would stay on the default 5 min and then turn off again. I switched out to my backup gun on the 2nd day of the match and didn't have any issues. My primary Shadow 2 had about ~4k rounds on it before the accelerometer broke and I used it only mainly for matches. It was an AD version.

 

The backup Shadow 2's Delta Point went bad today during practice. It has about ~10k rounds through it with the Delta Point and during practice the dot cut out. Inspecting it, I could see the same "slippage" of the contact to the battery on the circuit board towards the rear of the sight.  Its exactly like others have posted on this thread. It was an AE version.

 

I was planning on sending the 1st after the Washington State Championship this weekend and use it as a backup in case my backup died. Well, with the backup is dead now and the primary "iffy" at best with a broken accelerometer, looks like I'll be shooting another division.  It really has rattled my confidence in the Delta Point.  I'm sure Leupold will take care of both optics, I'm just not sure what I plan to do next.  Really sucks!  :(

Edited by Roons

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Roons said:

Sign me up for those having issues. I have two Shadow 2s both with Delta Point Pros each, and both have gone bad in a two week period. 

 

At the Oregon State match a couple weeks ago, the first Delta Point had the accelerometer go bad and the sight would not auto turn on. You can hear something rattling inside, and I needed to manually turn it on for every stage.  It would stay on the default 5 min and then turn off again. I switched out to my backup gun on the 2nd day of the match and didn't have any issues. My primary Shadow 2 had about ~4k rounds on it before the accelerometer broke and I used it only mainly for matches. It was an AD version.

 

The backup Shadow 2's Delta Point went bad today during practice. It has about ~10k rounds through it with the Delta Point and during practice the dot cut out. Inspecting it, I could see the same "slippage" of the contact to the battery on the circuit board towards the rear of the sight.  Its exactly like others have posted on this thread. It was an AE version.

 

I was planning on sending the 1st after the Washington State Championship this weekend and use it as a backup in case my backup died. Well, with the backup is dead now and the primary "iffy" at best with a broken accelerometer, looks like I'll be shooting another division.  It really has rattled my confidence in the Delta Point.  I'm sure Leopold will take care of both optics, I'm just not sure what I plan to do next.  Really sucks!  :(


You can slide the battery contact back into place, it usually takes at least a few hundred rounds before it moves again. Not an ideal solution, but workable. 

Edited by Rich406

Share this post


Link to post
Share on other sites

I spoke with Leupold today and they emailed me a RML to send both the Delta Points in for repair. Their customer service was awesome. They were empathetic and quickly got me a label out, apologized for the issues, and he made notes in the file that I'd love to have them back asap for matches. The tech mention they had a beefier board as well and would make the necessary update. We'll see how it goes when I get them back. 

 

Again, Leupold's customer service was awesome and assisted very quickly. :)

Share this post


Link to post
Share on other sites

They said the same for me.  I hope it works.  I went through 3 in 1 month, though, I admit I did do a lot of shooting that month

Share this post


Link to post
Share on other sites
1 hour ago, Roons said:

I spoke with Leupold today and they emailed me a RML to send both the Delta Points in for repair. Their customer service was awesome. They were empathetic and quickly got me a label out, apologized for the issues, and he made notes in the file that I'd love to have them back asap for matches. The tech mention they had a beefier board as well and would make the necessary update. We'll see how it goes when I get them back. 

 

Again, Leupold's customer service was awesome and assisted very quickly. :)

The turnaround on mine was just over a week total. They had it in their shop only two days.

Share this post


Link to post
Share on other sites

Well, I got both Deltapoints back from Leupold today. Took 3 weeks. Both of them had paper work saying they had "Bad Circuit Module" and replaced the Circuit Board. 

 

Unfortunately, they didn't actually fix the issue with unit ending with serial #AD that had the rattling sound and broken accelerometer. :(  I'm completely disappointed as you can clearly hear something inside the unit rattling. In addition to a note I included in the box explaining the issue with the unit, I explained it in detail prior to sending in. Its like they didn't even check the unit and disregarded the rattling sound. The unit will only turn on manually and turns itself off after 5 minutes. There is no way to keep it on even after trying other batteries besides the new one they sent back with the unit. 

 

Anyways, this unit will go back for repair today as I already called, they apologized, and are sending me another RML. Hopefully it won't take another 3 weeks. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...