Jump to content
Brian Enos's Forums... Maku mozo!

SP-01 trigger issues at the local IDPA match


selecw

Recommended Posts

I have a DA/SA SP-01 and was shooting it today in the local IDPA match when I started to have significant trigger issues....

I can pull the trigger all the way to the rear without the hammer dropping in either DA or SA mode.

The problem occurs with the slide on or off the frame.

With a magazine inserted, the hammer will drop some of the time.

Any theories?

I have an 8.5lb hammer spring and factory sear. The reduced TR spring is installed. The gun has about 3000 rounds through it and hasn't missed a beat so far.

Thanks for the help

Link to comment
Share on other sites

I am pretty new to the CZ platform and a very similar thing happened to me a month or two ago. Turns out people saying to use some loctite on the mag catch spring screw were right. Mine had backed out a bit and the trigger bar lifter spring wasn't doing its job anymore, so I'm with eerw and CZinSC, check the lifter spring.

Link to comment
Share on other sites

Is the trigger pushing back the hammer in DA and just not releasing it, or is it just "dead" and not doing anything?

I'm seconding the trigger bar lifter spring idea. Check to see that it hasn't come out of the grooves under the trigger bar. Sometimes you'll inadvertently snag them with a rag when cleaning and pull them off the trigger bar.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...