Jump to content
Brian Enos's Forums... Maku mozo!

1050 squeaky spring?


Recommended Posts

3 minutes ago, MemphisMechanic said:

(1) Replace with the Level 10 toolhead spring assembly. A vastly superior design that actually holds the head all the way up.

 

(2) Yes. Lube that bad boy. The squeak is usually the spring against the cup that it gets squished down into.

 

It is a level 10 spring and bushing. Just started squeaking today right at about 4000 rds 

Link to comment
Share on other sites

Use something like the red lithium grease. Use it on the ratchet part, case feeder slide (and spring) and the tool head case feeder cam piece. Use a motor oil on the main shaft. Sure I am missing some parts but you get the idea. Keep a tub of grease next press. 

Link to comment
Share on other sites

2 hours ago, MemphisMechanic said:

Ahh. Well then nevermind!

 

Mine hasn’t squeaked yet. But I did lightly grease the inside of the cup when installing it.

Did that to with the grease on the cup. Gonna load up 2k more tomorrow then take tool head off to put the shell plate bearing on and lighter detent ball. 6-7k rds should be good to take apart and clean anyway and re oil parts. I know about all the oil points. It’s weird how it all of a sudden started squeaking like that. Will put some gun oil on the spring this time just put it in dry when I first put it in. 

Link to comment
Share on other sites

4 hours ago, Dirtchevy841 said:

Did that to with the grease on the cup. Gonna load up 2k more tomorrow then take tool head off to put the shell plate bearing on and lighter detent ball. 6-7k rds should be good to take apart and clean anyway and re oil parts. I know about all the oil points. It’s weird how it all of a sudden started squeaking like that. Will put some gun oil on the spring this time just put it in dry when I first put it in. 


 

no gun oil 

 

grease

Link to comment
Share on other sites

9 hours ago, MemphisMechanic said:

(1) Replace with the Level 10 toolhead spring assembly. A vastly superior design that actually holds the head all the way up.

 

(2) Yes. Lube that bad boy. The squeak is usually the spring against the cup that it gets squished down into.

 

 

Lube the spring, as stated in the manual, and if you didn't get the spare parts kit, when it's time to replace, go for the level 10 kit as stated above.

 

When I got my 1050 in 2007, I got the spare parts kit, and replaced the spring with with the spae.  I replace that one last year with the Level 10 and couldn't be happier.

Link to comment
Share on other sites

1 hour ago, MemphisMechanic said:


There. Fixed it for you. 😈😁

😂 about to take the ratchet off. Have a ponsness Warren autodrive being delivered tomorrow. Got a great deal from a friend like new with custom control panel. Gonna try to see if I like before spending the extra money for a ammobot or m7. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...