Jump to content
Brian Enos's Forums... Maku mozo!
woodrow

prochrono serial/usb pinout

Recommended Posts

woodrow   

i was wondering if anyone has the pinout for the usb connector for the prochrono. i read that competition electronics has reversed the polarity on the cable so if you were to make your own chrony cables it's better to make an extension adapter with the leads reversed instead of making another cable.

anyways i've seen the cables done and such but i just want to solder one up on my bench really quick and was wondering if anyone has the pinout for how this needs to be done. thanks guys!

Share this post


Link to post
Share on other sites
digadv   

I would like to know also, but I tried a more simple test ...

I've tried to get a simple serial port to connect to the unit using the CE software on their webpage. While I can get the unit to respond to commands from the software, I can not receive any data. It appears that the unit's TX signal does not meet RS232 signal specs (+/- 12V). Any feedback would be appreciated.

Share this post


Link to post
Share on other sites
1953naa   

I too am having some difficulty sorting out the ProChrono serial port. I've tried to get it to work with a PL2303HX USB to TTL module as well as an FTDI FT232R USB to Serial module running at 5V and I get nothing but a CErr on the chrony. Switching TX & RX didn't seem to make a difference.

Has anyone had any luck DIYing your own interface to the ProChrono? Is it 3.3 or 5V TTL level or is it true RS232 serial communication that is needed? What is the pinout on the ProChrono jack--- I'm pretty sure the base of 3.5mm jack is ground and I believe the tip is the TX from the chrono (connects to RX on USB adapter) but is this indeed the case?

I appreciate any guidance members of this forum can provide on this!

Ron

Share this post


Link to post
Share on other sites
digadv   

I believe you're right on the ground identification because it ohms out with the "-" on the battery terminal. However, if I connect the grounds (computer and chrono), my transmit path to the chrono stops working. Without the grounds connected, my software correctly controls the chrono with RS232 levels. However, I can not get any information from the chrono. When the grounds are connected, it seems to bias the signal up so that I do not get the full -12V swing ... more like -5V and software stops working.

Surely someone has successfully done this - we just need to find them :huh:

Share this post


Link to post
Share on other sites
adam3999   

Does anyone have an update on this? I'm in the same boat. With the TX and RX pins only, no ground, I can successfully change strings, re-display, review, etc. I can't get statistics or velocities, however. It appears transmitting to the chrono works fine but I can't receive any data from it. I've tried both my PC's serial port and a USB-to-serial adapter, under Windows XP and 7. Any help would be appreciated, thanks.

Share this post


Link to post
Share on other sites

It sounds like you've converted the voltages property (TTL to RS-232). FYI, I used a MAX233 chip.

I could never quite figire out the rationale for how they pulled velocities from the chronograph. I'm pretty sure there must be a very cerebral checksum or something that was lost on me.

I'll take a look at my hack of a program when I get home (at the inlaws) and post what I did.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×