Jump to content
Brian Enos's Forums... Maku mozo!

Vortex venom question


parabat
 Share

Recommended Posts

Have you zeroed it or tried to adjust the zero in the up direction? I’d turn it up and see if you can see the dot in more of the window.

I may be wrong in the direction as I’ve never had this issue but I’ve heard of the dot disappearing if the adjust is off too far in one direction.

Link to comment
Share on other sites

2 hours ago, parabat said:

Allright ty, i havent zeroed it yet, ill make sure to check that.

 

Seems just weird to me that it dissapears in the top half, thought maybe someone with a venon could confirm if its normal or not?

It's not normal, on my Vortex Venom, i can see the dot on all glass surface. 

Link to comment
Share on other sites

I can also say no it's not normal. I too can see the dot everywhere on the glass.

 

Also, I installed my venom on my glock mos in 2017, and have shot many thousands of rounds. It's still mounted as it was (blue loctite) and the settings (dials) stay as they are. It has some nicks on the frame from brass bumping to it, but the glass is still very smooth. I'm happy with it so far.

 

However, I might want to get the 6MOA version for my next gun. I heard it's brighter!

 

 

Link to comment
Share on other sites

I had two Venoms that were defective with its elevation, had them mounted on two separate SP01’s and they both literally went out during the same match in during a stage. Sent them back to vortex and they got replaced. I never noticed that the dot disappeared in the window however.

Link to comment
Share on other sites

22 hours ago, OdinIII said:

Have you zeroed it or tried to adjust the zero in the up direction? I’d turn it up and see if you can see the dot in more of the window.

I may be wrong in the direction as I’ve never had this issue but I’ve heard of the dot disappearing if the adjust is off too far in one direction.

 

You were right, i the adjust was way off in one direction (down) i turned the adjust up and the problem is gone now.

 

Thank you very much, i never heard that this was possible, but im glad its fixed now.

 

Thanks!

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...