Jump to content
Brian Enos's Forums... Maku mozo!

2011 slide doesn't go to the battery.


cheby
 Share

Recommended Posts

Occasionally, when I reload with a  fully loaded magazine, the first round from the new magazine doesn't go to the chamber completely. I'd fire the round in the chamber and then it happens. Sometimes I have to push the slide with my left hand  or it goes by itself with some delay.  It doesn't happen often but the last two occasions happened at the matches and annoyed me. The springs, both magazines and recoil, are newish. If the magazine is not fully loaded it doesn't happen. It happened with several magazines including mbx and svi with grams gutts.  Any idea? Something is dragging. Perhaps the gun/magazine was dirty. Perhaps the lips or?

 
Link to comment
Share on other sites

3 hours ago, Dwbsig said:

What kind of ammo are you shooting?

Blue bullets.  I am pretty sure that FMJ would feed better in theory but I shot a lot of blue bullets for the last few years. Money talks

Link to comment
Share on other sites

10 hours ago, cheby said:

Blue bullets.  I am pretty sure that FMJ would feed better in theory but I shot a lot of blue bullets for the last few years. Money talks

I just wondering if your ammo was on the weak side that could cause your problems.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...