Jump to content
Brian Enos's Forums... Maku mozo!

Shadow 2 trigger bouncing back when slowly pulling in SA


marcool
 Share

Recommended Posts

I will try my best to describe the problem with my Shadow 2.  I swapped to 11.5lb hammer spring and installed reduced trigger return spring and reduced sear spring in this Shadow 2.  It's 5.5lb in DA and 1.5lb in SA, very nice.  However after ~500 rounds the problem started showing up.  In SA, if I pull the trigger slowly, the sear would release the hammer prematurely without the full force.  Then the trigger bounces my finger back with a fairly strong force (it's definitely from the hammer spring, not the trigger return spring).  And then the hammer would drop halfway, held there as my finger still on the trigger pressing it.  I have to pull the trigger again which is already in the DA mode to let the hammer raise and drop to fire the round.  I shoot IPSC and this problem becomes very annoying and definitely slows me down.  In DA there is no issue.  In SA if I pull the trigger quickly this is no issue.  I also notice if I lubricate the sear assembly it becomes much worse. 

 

I have another shadow 2 with the same setup and does not have this issue at all.  What do you think the issue is and any suggestions for a fix?  Thanks.

Edited by marcool
Link to comment
Share on other sites

On 8/14/2020 at 6:47 PM, SouperMan said:

It might be the Sear Spring. It might be too weak. 
 

Also, I also want to say it might be the triggerbar spring, but you say it’s ok in Double Action so the triggerbar spring might not be the issue. 

Thanks!  I will try to switch back to the stock sear spring and see if it helps.

 

2 hours ago, rowdyb said:

What exactly non stock parts do you have in the gun? From which company? Who installed them?

The reduced trigger return spring and the reduced sear spring are from Mcarbo.  The 11.5lb hammer spring is from Cajun.  I have them installed and I've done these quite a few times with no problem.  I have my other Shadow 2 with the exact the same setup and have no issue at all.

Link to comment
Share on other sites

Update:  I swapped back to stock sear spring and the issue is improved by ~80%, with both DA/SA pull both increased by half pound that I can live with (6lb/2lb).  I switched to 13lb hammer spring and the problem is completely gone.  Unfortunately the DA pull becomes 7.5lb and it’s too heavy for me.  


I guess this shadow 2 sear assembly just happens to have low tolerance of reduced power hammer spring compared to my other one which handles the reduced sear spring and 11lb hammer spring.

Link to comment
Share on other sites

15 hours ago, marcool said:

Update:  I swapped back to stock sear spring and the issue is improved by ~80%, with both DA/SA pull both increased by half pound that I can live with (6lb/2lb).  I switched to 13lb hammer spring and the problem is completely gone.  Unfortunately the DA pull becomes 7.5lb and it’s too heavy for me.  


I guess this shadow 2 sear assembly just happens to have low tolerance of reduced power hammer spring compared to my other one which handles the reduced sear spring and 11lb hammer spring.

Try clipping the factory 14# hammer spring until you get 5.5# d/a. 

Link to comment
Share on other sites

1 hour ago, hal1955 said:

Try clipping the factory 14# hammer spring until you get 5.5# d/a. 

 

Thanks but I'm afraid that will bring the issue back.  I have various iteration and figure out it's the trade-off between the pull weight and this problem.  It's quite obvious the issue is essentially a hammer and sear fitting/alignment issue, an out of box luck.  I tried searching in this forum on hammer/sear adjustment but couldn't find much about it.

Link to comment
Share on other sites

10 minutes ago, marcool said:

 

Thanks but I'm afraid that will bring the issue back.  I have various iteration and figure out it's the trade-off between the pull weight and this problem.  It's quite obvious the issue is essentially a hammer and sear fitting/alignment issue, an out of box luck.  I tried searching in this forum on hammer/sear adjustment but couldn't find much about it.

I have done that trick to half a dozen Shadows and Shadow2 over the years. Worked every time. 5.5# da/ 2.25# sa. Clip 3 or 4 coils and see what happens. You are probably not using the factory spring anyways😀

Edited by hal1955
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...