Jump to content
Brian Enos's Forums... Maku mozo!

Evo Manual Powder Measure Issues

Recommended Posts

Just got the First Evo in yesterday and was setting it up, everything is good except for the powder measure, wanted to see if anybody else has had this problem.   I run a MA bell die in station 5 have it set perfectly for the bullet. Then set the powder die to depth so it moves the measure screw to the top and should dump a charge and not bell the brass.  Went to set the powder charge and screw the meter screw in (clockwise) for no powder and it will not actuate the drum, it locks up funnel and splits the case,  With the meter screw, screwed more than have way out,  it will will still not move through the cycle and throws no powder.  Backed out meter screw all the way it may throw less than a 1gr of powder (didn't measure).  I have not seen where the meter screw would lock up the powder measure and funnel when more than half way in.  Any Ideas? 

Link to comment
Share on other sites

Sorry this reply is late, but have you tried simply actuating the powder measure by hand(using your hand to flip the adjustment screw up and down as if it were throwing powder)? If not, try doing it by hand to see if there is something binding internally. Mine is set up for .223, so I can't directly compare it to one set up for 9mm, but mine has been smooth as silk the whole time, whether I had the adjustment screw all the way in or all the way out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...