Jump to content
Brian Enos's Forums... Maku mozo!

Cz rami issues


Novajx2289
 Share

Recommended Posts

Hey y’all, im New to the forums. I bought a new cz rami last weekend and I’m having FTF issues. What’s happening is the rounds in the magazine are being unseated and pushed halfway forward causing my rounds to hit the feed ramp head on and stop, sometimes the last round is so far forward the last round pops up out of the gun lol. I’ve polished the third rail and knocked down the sharp edge at the bottom of the breech. I’m still seeing drag marks on the top round. Any advice would

be great. Thanks !

518DB9B9-5155-4D4E-9FF3-4190EFA06705.jpeg

Link to comment
Share on other sites

Is your ammo factory ammo or hand loaded?  Are your problems occurring with just one type of ammo?  Have you tried different ammo with different weight bullets, different bullet profiles, different OAL's etc.?

 

A little more information would help in attempting to offer suggestions to help you out.

 

Are you using factory OEM CZ magazines?  If so, are they the 10-round or the 14-round magazines?

 

Is your problem occurring with more than one magazine?

 

Not sure what you mean by your statement that you have knocked down the sharp edge at the bottom of the breech.  Are you saying you have altered the profile of the feed ramp?

Link to comment
Share on other sites

Sorry, I wrote that kinda fast. No I didn’t alter the feed ramp angle or anything like that. I will attach a picture of the area I was talking about. It’s just a problem area I have read about on cz forums. Just curious if this part is dragging on the top round that’s in the mag.
 

it’s happening with every type of factory ammo I ran.  No hand loads. 115, 124 grain, And 147 grain are all doing it. The problem is occurring in both factory new magazines. So both the oem 10 round and 14 round mags.  It did not FTF every time but was fairly consistent when it did, same problem every time too, the top round in the magazine was moved halfway up in the mag Causing it to hit the feed ramp like in the picture and just stop. sometimes the last round just popped out of the magazine it was pushed so far forward. Thanks 

03FB5C44-04F9-4D17-B65D-24AAB4B4E08C.jpeg

Link to comment
Share on other sites

Given the new information you have provided, I agree with the post above.  Send it back to CZ and include all your data and photos.  The gun should run factory ammo, and it doesn't.  Tuning it or getting someone to tune it on your dime are also options, but you should make CZ stand behind their product, and I think they will.  Good luck.

Link to comment
Share on other sites

  • 2 weeks later...

Typically when this happens its because the leading edge of the runway has a slight too sharp of edge to it. It pulls the round forward in the magazine when the slide moves forward.

Diamond file, and a little time will fix it.

 

Round off the front edge ever so slightly, and that will normally fix that issue. Also polishing the runway as well tends to help.

 

This is a pretty common issue on Tanfos, and Ive managed to make all my pistols not drag rounds forward with this fix.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...