Jump to content
Brian Enos's Forums... Maku mozo!

Shadow 2 Trigger Help


Recommended Posts

I recently switched to the shadow 2 and don’t know the internals as well as some other guns. I was at the range today when the gun suddenly developed a trigger issues. I have about 5k rounds on the gun and bought it used. It was used very little before I got it. It has the Cajun trigger kit installed. 

The issue is that the trigger suddenly doesn’t work in double action. Had just loaded the gun and manually decocked before holstering. Nothing felt strange. Upon drawing and attempting to shoot, the trigger moves without the hammer. I noticed that I could pull the hammer back about a millimeter and heat and feel a click. The trigger works at that clock. It is not the half cock position as I can still pull the hammer back further and have it stop at half cock. So there are now 4 positions. Where it rests after being decocked or dry fired, the first click where it works, half cock, and fully cocked. 
 

I took the gun apart and can’t figure out why this is happening yet. Any help would be appreciated.  
 

 

Link to post
Share on other sites

Does the trigger shoe have a set screw in it? Mine had this problem and it was because the set screw to adjust pre travel backed out and wouldnt let the double action reset.

Sent from my SM-G965U using Tapatalk

Link to post
Share on other sites

Ha!  Trigger set screw was it. Should have checked that before taking the whole thing apart. I’m an idiot. 
 

Noticed I lost my overtravel set screw. Anyone know of a place to get one?

 

Thanks for the help! 

Link to post
Share on other sites
47 minutes ago, hitman_usmc said:

Got some replacement screws.  Nothing further needed.  Thanks again. 

Make sure you loctite them in place or else you'll have the same issues again, trust me on that. Blue worked well for me

Link to post
Share on other sites
  • 3 weeks later...

I just went through this myself.  Good to know threads like this are out there to help those not as familiar with these guns as others.

Link to post
Share on other sites

My S2 took a dump on me at the range today. Single action ok, double action no go. Everything looked ok, trigger screw, trigger bar spring,trigger return spring etc. Finally went home and took it apart, there was a tiny pebble about the size of a pin head between the trigger bar at the front and the frame. Trigger could not move far enough ahead to reset. I figure the pebble hitchhiked in via a mag since I was practicing mag changes at the time. I did give the mags a shake and a wipe between changes but that one got by me.

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...