Jump to content
Brian Enos's Forums... Maku mozo!
Sign in to follow this  
Qwikrex

Staccato P Duo, hollow points nose dive

Recommended Posts

Posted (edited)

Picked up a 2020 Staccato P duo on Saturday. Put about 250 rounds of 124 and 115 gr FMJ's without issue. I then put about 125 rounds of 124 gr HST's through, which was working fine up until the last few mags. Now with the HST's, whenever I attempt to chamber the first round in any of my mags, the round nosedives onto the middle of the barrel feed ramp. It happens less often with some Winchester 147gr JHP's that I have, but it still happens with them over 50% of the time. Happens both when reloading from slide lock, or when racking the slide. Once the first round chambers, the rest of the mag seems to fire fine. FMJ's still chamber fine. Any ideas on where to start? Any help would be much appreciated.

Edited by Qwikrex

Share this post


Link to post
Share on other sites

I’ve got about 600 147gr HSTs through mine with zero issues and about that many acme reloads. Best bet is to contact sti they had a bunch of bad mag releases get out. 

Share this post


Link to post
Share on other sites

I'd probably contact STI to see if they have any thoughts, given assume you're using the factory mags. I would assume given the LEO focus of the Staccato P they must tested HST with the factory combo.

 

Otherwise the next place to look is trying different mags I'd think. Maybe first can try extra power mag springs (by Atlas), or different mags altogether (MBX). 

Share this post


Link to post
Share on other sites
1 hour ago, Qwikrex said:

Picked up a 2020 Staccato P duo on Saturday. Put about 250 rounds of 124 and 115 gr FMJ's without issue. I then put about 125 rounds of 124 gr HST's through, which was working fine up until the last few mags. Now with the HST's, whenever I attempt to chamber the first round in any of my mags, the round nosedives onto the middle of the barrel feed ramp. It happens less often with some Winchester 147gr JHP's that I have, but it still happens with them over 50% of the time. Happens both when reloading from slide lock, or when racking the slide. Once the first round chambers, the rest of the mag seems to fire fine. FMJ's still chamber fine. Any ideas on where to start? Any help would be much appreciated.

It's the weak mag springs.  Replace with ISMI 11 coil and the issue will go away.  I have 4 of them and they all had issues with flat nosed ammo with the stock springs.  

Share this post


Link to post
Share on other sites

Where do you get the springs? I’d like to have some on hand. 

Share this post


Link to post
Share on other sites

I ordered from Shooters Connection, but you can buy the direct from ISMI.  

Share this post


Link to post
Share on other sites
32 minutes ago, RangerTrace said:

It's the weak mag springs.  Replace with ISMI 11 coil and the issue will go away.  I have 4 of them and they all had issues with flat nosed ammo with the stock springs.  

 

Would these be the ones? https://www.brownells.com/magazines/handgun-magazines/magazine-parts/magazine-springs/ismi-sti-magazine-spring-sku445126100-24804-18786.aspx

Share this post


Link to post
Share on other sites

Awesome. I'll give those a shot. Will these springs work on both the 20 rounders and the 17 round mags?

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, ClayBuster said:

I’ve got about 600 147gr HSTs through mine with zero issues and about that many acme reloads. Best bet is to contact sti they had a bunch of bad mag releases get out. 

 

Are you still running the original mag springs? I called STI earlier, and they said to submit a warranty claim. They did mention that they were aware of issues with the staccato p and hollow points. They cited having issues with magazines and mag catches and were currently redesigning them. They didn't offer to send one though. I'll try new mag springs first and go from there I suppose.

Edited by Qwikrex

Share this post


Link to post
Share on other sites

Yes sir, and a bunch of my old G2 mags, zero issues with any of them. 

Share this post


Link to post
Share on other sites
1 hour ago, Qwikrex said:

Awesome. I'll give those a shot. Will these springs work on both the 20 rounders and the 17 round mags?

Yes.  You may lose a round of capacity on the 17 rounders, but I only load them to 10 for IDPA anyway.

Share this post


Link to post
Share on other sites
1 hour ago, ClayBuster said:

Yes sir, and a bunch of my old G2 mags, zero issues with any of them. 

 

Gotcha. Also I forgot to ask, do you have a 2019 staccato P or a 2020 with the updated grip frame/4.4" barrel?

 

Share this post


Link to post
Share on other sites
2 minutes ago, Qwikrex said:

 

Gotcha. Also I forgot to ask, do you have a 2019 staccato P or a 2020 with the updated grip frame/4.4" barrel?

 


2020 with the s#!tty G2 grip. 

 

Share this post


Link to post
Share on other sites
19 minutes ago, RangerTrace said:

Yes.  You may lose a round of capacity on the 17 rounders, but I only load them to 10 for IDPA anyway.

 

Ok, thanks again.

Share this post


Link to post
Share on other sites
1 minute ago, ClayBuster said:


2020 with the s#!tty G2 grip. 

 

 

Lol. At least yours is running well.

Share this post


Link to post
Share on other sites
18 minutes ago, Qwikrex said:

Nice. Did you get the original grip redone or did you replace it with a Gen 1?

 

Sent the original to extreme shooters, took about a week door to door, much better now. 
 

Share this post


Link to post
Share on other sites
On 3/30/2020 at 1:43 PM, RangerTrace said:

It's the weak mag springs.  Replace with ISMI 11 coil and the issue will go away.  I have 4 of them and they all had issues with flat nosed ammo with the stock springs.  

 

Ok, so I got the ISMI 11 coils in. Tried it out in one of my mags. And it's still doing the same thing. Funny part is, if I ride the slide and chamber it real slowly, hollow points chamber just fine. But if I try to load it from slide lock and press the slide release, the round nosedives into the bottom of the ramp. Not sure what else I can do. I opened a warranty claim with STI, but I'd rather fix it myself if possible. 

Share this post


Link to post
Share on other sites
6 minutes ago, Qwikrex said:

 

Ok, so I got the ISMI 11 coils in. Tried it out in one of my mags. And it's still doing the same thing. Funny part is, if I ride the slide and chamber it real slowly, hollow points chamber just fine. But if I try to load it from slide lock and press the slide release, the round nosedives into the bottom of the ramp. Not sure what else I can do. I opened a warranty claim with STI, but I'd rather fix it myself if possible. 

This is a 9mm right?  Will it chamber if you sling shot the slide?  Does it FTF when actually shooting?  I had a couple Wilson Combat pistols in .38 Super that would FTF all day long when chambering by hand, but fed just fine while shooting.

Share this post


Link to post
Share on other sites
9 minutes ago, RangerTrace said:

This is a 9mm right?  Will it chamber if you sling shot the slide?  Does it FTF when actually shooting?  I had a couple Wilson Combat pistols in .38 Super that would FTF all day long when chambering by hand, but fed just fine while shooting.

 

Yup 9mm. If I slingshot the slide with mag inserted and the slide at rest, it will chamber. If the slide is locked back and I slingshot, it will nosedive still. The gun fed federal HST's fine at the range. It hasn't had a FTF while shooting HST's. It's just chambering the first hollow point in a mag where I'm having the issue. 

 

My concern is, if I ever need to reload from slide lock,  it doesn't seem to do that reliably. 

Share this post


Link to post
Share on other sites
2 minutes ago, Qwikrex said:

 

Yup 9mm. If I slingshot the slide with mag inserted and the slide at rest, it will chamber. If the slide is locked back and I slingshot, it will nosedive still. The gun fed federal HST's fine at the range. It hasn't had a FTF while shooting HST's. It's just chambering the first hollow point in a mag where I'm having the issue. 

 

My concern is, if I ever need to reload from slide lock,  it doesn't seem to do that reliably. 

I understand completely.  I shoot IDPA mainly these days, so slidelock reloads are mandatory.  Plus, two of these guns are duty guns for me.  The better mag springs solved my issue with BBI Gen1 flat nozed 147s, Speer Gold Dot 124 +P and Zero 147 JHP ammo.  I'm running the newest STI tubes and followers with 11 coil ISMI springs.  I should mention that I'm using the same springs in both 126mm and 140mm mags.  

Share this post


Link to post
Share on other sites

I was pretty sure it wasn’t the springs. There’s something wrong with the G2 grip/mag release combo on some of the guns. I knew this when I bought mine and was fully prepared to swap to a G1 grip but mine works fine. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...