Jump to content
Brian Enos's Forums... Maku mozo!
Sign in to follow this  
war_material

Back to the Stock 2 (CO)

Recommended Posts

Anybody else throwing an optic on a stock 2 with this new weight change? I will be going going with an SRO and henning extensions. Dry fired a bunch so far and taking it for a spin tomorrow. I used to shoot the stock 2 in production and went to CO. Since then it’s been Glocks and sigs, even dabbled in open a bit with an Sti but I always missed the tanfo but never bothered to try and make it make weight for CO. Anybody been shooting this setup? It’s an EGW sight adaptor.

 

fc991916f0318f1292f32fbd23bc0007.jpg

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I use the same setup on a Lim Pro (made 'old weight, which the S2 didn't).  Works well.  Stoeger liked it when he shot a few rounds.

 

Share this post


Link to post
Share on other sites
I use the same setup on a Lim Pro (made 'old weight, which the S2 didn't).  Works well.  Stoeger liked it when he shot a few rounds.
 

That’s awesome! Have you ever had any issues with the mount? I never shot a sight mounted optic before.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
7 hours ago, war_material said:


That’s awesome! Have you ever had any issues with the mount? I never shot a sight mounted optic before.


Sent from my iPhone using Tapatalk

 

Nope, clean out the screw holes and sight screws, dab on a little loctite and tighten everything down.  I use a torque wrench just to be sure, but they've been solid once loctited.  Btw, just screwing the sight down without loctite will not work long term.

 

I'm an old-time Open shooter so a bit of height over the slide isn't a big deal.  I'd rather a lower plate, but Henning doesn't make one for the SRO.

 

Maybe someday I'll mill the slide, but I don't think the sight plate is holding me back any.

 

Share this post


Link to post
Share on other sites

I too am switching back to CO.  Years ago I had a custom made mount for my LimPro and had an RMR on it. It made the old weight but at border line.  I had the S2 as a backup.  It takes getting use to in finding the dot since the optic sits higher that where the iron sight would be.  With the new weight, the S2 has a place in the CO game.  I  am still undecided if i am to have the slide milled or not.  But having the slide milled puts the dot closer to the bore axis.

Share this post


Link to post
Share on other sites
 

Nope, clean out the screw holes and sight screws, dab on a little loctite and tighten everything down.  I use a torque wrench just to be sure, but they've been solid once loctited.  Btw, just screwing the sight down without loctite will not work long term.

 

I'm an old-time Open shooter so a bit of height over the slide isn't a big deal.  I'd rather a lower plate, but Henning doesn't make one for the SRO.

 

Maybe someday I'll mill the slide, but I don't think the sight plate is holding me back any.

 

That’s good to know thanks! Yeah I don’t mind the height either, I guess I was just worried about the sight mount moving side to side and throwing off the zero. I tightened it pretty hard but I wished the screw would or lined up with one of the indent holes or it had 2 screws. Oh well maybe I’m overthinking it just need to shoot and see what happens. I will have to put loctite on the screw too

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Just sighted it in today and got some light strikes. May have been the ammo and the cold. Gonna keep on running it and just ordered another from JoAnna at PD.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
1 minute ago, war_material said:

Just sighted it in today and got some light strikes. May have been the ammo and the cold. Gonna keep on running it and just ordered another from JoAnna at PD.


How is the gun sprung, and are you running a bolo and a racey hammer?

 

Remember you’re back to the land of the hammer-fired gun. Where a primer that’s merely flush is a high primer, and won’t go bang with lighter springs. 😁

 

Share this post


Link to post
Share on other sites

How is the gun sprung, and are you running a bolo and a racey hammer?
 
Remember you’re back to the land of the hammer-fired gun. Where a primer that’s merely flush is a high primer, and won’t go bang with lighter springs.
 

Yes Sir it’s a welcome back alright hahaha. I am running a

stock hammer
Xtreme 1 pc sear
Pd sear spring
Pd trigger return spring
10lb recoil spring
Pd guiderod
Extended fpb

And for the life of me I don’t remember what hammer spring I am running but I think it is the Pd 15.5 but not sure. I set this thing up in 2017 so it’s hard to remember. Been in the safe since. I reload on a 1050 and just increased the depth setter. I will make sure to hundo all my match rounds. But man yeah when the light strikes came today I said “here we go” haha


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Just put in a Pd 14lb I had laying around it was much longer than the one that was in there. Hopefully helps


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I put the EGW mount on my stock 2 a couple of months ago along with a SRO and I’m very happy. First time I mounted the red dot I didn’t put enough locktite on it. Second time did it right. With my 60 year old eyes CO is the only way to go. 

Share this post


Link to post
Share on other sites
I put the EGW mount on my stock 2 a couple of months ago along with a SRO and I’m very happy. First time I mounted the red dot I didn’t put enough locktite on it. Second time did it right. With my 60 year old eyes CO is the only way to go. 

Nice! Are you talking about loctite in the screws for the dot itself or the small set screw for the mount in the sight block? That’s good to hear. I just put lok grips and took it out yesterday. The gun feels so good. da99bfb0f78d1032e8b49bf6cd3cbd29.jpg


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Both. The set screw to the slide worked loose as there is only one screw but one of the screws for the SRO was loose also. Not anymore 😎

 

by the way war_Material my sister lived in minot during the early 80’s, her husband was the pastor at he Nazarene church in sawyer. 

Share this post


Link to post
Share on other sites

This may or may not help with the lite primer hits but I bought a lot of CCI primers (had been using Federal) for a good price and shortly after begin to have lite hits on all my Tanfos. On a guess I traded the CCIs for some Winchester primers and ....voila.....lite hits went away. 

 

Hope this helps as the lite hits are bad juju......especially in a match.

 

 

 

Share this post


Link to post
Share on other sites
Both. The set screw to the slide worked loose as there is only one screw but one of the screws for the SRO was loose also. Not anymore
 
by the way war_Material my sister lived in minot during the early 80’s, her husband was the pastor at he Nazarene church in sawyer. 

That’s awesome what a small world. I live near sawyer and have a friend there.

I will definitely get the set screw situated before I start going hard lol.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
This may or may not help with the lite primer hits but I bought a lot of CCI primers (had been using Federal) for a good price and shortly after begin to have lite hits on all my Tanfos. On a guess I traded the CCIs for some Winchester primers and ....voila.....lite hits went away. 
 
Hope this helps as the lite hits are bad juju......especially in a match.
 
 
 

Man I switched to the stock hammer spring and no more lite strikes with cci. But it’s a heavy first pull lol. I tried the 15.5 Pd with a coil cut off to let the hamme go back all the way but the pencil test was super weak I didn’t even bother to bring it to the range. I have a titan hammer but it it doesn’t seem to make a difference in the pencil test. It’s like it releases very early.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Yep that's the trade-off for a heavier hammer spring. 

Share this post


Link to post
Share on other sites

Fixed it 100% ignition with 15.5 Pd spring with 1 coil cut off to allow hammer to go all the way back. CCI and Winchester seated .005-.007 with 1050. Trigger is as good as it gets in my opinion!


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
On 3/25/2020 at 2:54 PM, N7VY said:

Both. The set screw to the slide worked loose as there is only one screw but one of the screws for the SRO was loose also. Not anymore 😎


Loctite all the things. Don’t wanna be like poor Rob, blasting his own optic on the first stage of a Major.

 

 

Share this post


Link to post
Share on other sites

Loctite all the things. Don’t wanna be like poor Rob, blasting his own optic on the first stage of a Major.
 
 

Awww man that sucks lol!! Yeah took it all apart and applied the liquid blue goodness. Just went to confirm zero today and it didn’t change. Thanks again for all the videos on the polishing and everything it was a lot of work but shooting this gun is like driving a fine race car I never wanna stop!


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I’ve found that using PD extended firing pin really solved all of my light strikes. No change in hammer spring , just a bit more meat on the pin. 

Share this post


Link to post
Share on other sites
I’ve found that using PD extended firing pin really solved all of my light strikes. No change in hammer spring , just a bit more meat on the pin. 

Interesting, I didn’t think of trying one out. I will definitely test it out some time. Thanks for sharing! I ran an old xtreme medium I had laying around yesterday and had no light strikes and no changes to my times. But it is noticeably heavier. I will definitely experiment some time though


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I switched out my upper while I was having the slide lightened and forgot to put the extended firing pin in the replacement slide and during a match I had about 15 repeated light strikes ( I have a double action lower ). Several competitors commented on the amount of light strikes. I knew what it was and after the match I switched out the shorter one for the PD extended firing pin. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...