Jump to content
Brian Enos's Forums... Maku mozo!

Odd Hyperfire issue


Recommended Posts

I shot Steel challenge today with PCC. Gun is a QC10 (upper, lower, barrel and BCG) and ran perfect with a variety of ammo but on the last 5 shots of the match I had to manually cycle the bolt before I could shoot.  I looked into it a bit further when I got home discovered that the hammer wasn't releasing when I pull the trigger.  As it turns out, there was buildup on the dual spring assembly which prevented the trigger from releasing. I removed everything, cleaned it and reinstalled it and all is good now. I'm using the heavy springs(which provide the lightest trigger pull). I wonder if the medium or light springs would have still allowed it to function. Anyone else have a problem like this with Hiperfire?

PCC is dirty and I'm wondering how often folks clean the inside of their lower.   Prior to this match I had about 1000 rounds through it with the 243G installed so I sprayed some brake clean in the FCG without removing it and blew it out with air.

Edited by Ryan N
Link to comment
4 hours ago, Ryan N said:

 I'm using the light springs. I bet the medium or heavy spring would have still allowed it to function. Anyone else have a problem like this with Hiperfire?

I thought that everyone used the heavy springs since they give the lightest trigger pull. Do you like a higher trigger pull?

Link to comment
4 hours ago, Gregg K said:

I thought that everyone used the heavy springs since they give the lightest trigger pull. Do you like a higher trigger pull?

I think your correct.  I'm using the heavy springs which yield the lightest trigger pull.  I have edited OP for clarification.

Edited by Ryan N
clarification
Link to comment

Same thing happened to my Hiperfire eclipse when brass shavings got wedged and won’t reset. Sprayed it with non-chlorinated brake cleaner and blow it diwn using my air compressor.

 

I have an MPX so I clean it after every 1000 rounds or so because it gets dirty.

Link to comment
  • 2 weeks later...

Safety concern:  if you experience "dead trigger" (hammer not releasing when trigger is pulled), be aware that once you pull the trigger the hammer could release at any moment.  I recommend promptly unloading (while pointing in safe direction) and fully cleaning FCG components.  I had an instance when I pressed the trigger and the hammer release a second or 1.5 seconds later.  This happened about 1100-1200 rounds after I installed the 243G(with no cleaning inside lower).

 

I now plan to remove FCG and clean every 700-800 rounds.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...