Jump to content
Brian Enos's Forums... Maku mozo!

Feed Ramp Jam


tke37617
 Share

Recommended Posts

I have a couple 170 STI tubes with Grams Springs and new STI followers.  If packed tight with 28-29 rounds of 9 major, 1 magazine will consistently jam the first round into the feed ramp and not chamber.  The other magazine will only do this occasionally.  If I load each magazine down 1-2 rounds they will both run great.  It is a very slight downward angle (nose dive).

 

My four 140 mags which are identical except for the length of the tubes function flawlessly all of the time when packed tight to the absolute max.

 

Thanks in advance for any ideas.

 

Link to comment
Share on other sites

No spacers in any of the mags.

 

Grams springs are less than 2 years old.  1 of the 170 mags did this first trip to the range.

 

I have not checked the feed lips.  I will do this and report. 

 

All mags were tuned from the gun builder and bought new with the gun.  Everything is great except for the 170s.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...