Jump to content
Brian Enos's Forums... Maku mozo!
AWZ1387

Normal wear, guide rod?

Recommended Posts

I went to the range today and while cleaning my glock 34 I noticed that there is some wear on the jager guide rod. One side of the base the finish worn off and it is slightly flattened. There is also a couple of scratch marks next to the flattened area. I don't see any new wear on the barrel or frame. So I am not sure where it is rubbing/hitting.

I only shot 300 rounds since installing the guide rod. I was shooting federal champion 115gr.

I had a 14lbs wolff spring on the rod. I have a tti trigger kit installed, if that makes a difference. 

I took some photos. 

Photo link

Edited by AWZ1387

Share this post


Link to post
Share on other sites

I've had half dozen Jager rods and have seen some slight scratches form and the bottom edge on one tried to burr up a little after thousands of rounds but nothing I couldn't easily knock down with a stone. 

This definitely looks like something isn't fit correctly to cause that kind of wear so quickly.  Are you sure it's the correct rod for your generation of gun?  Was it possibly not seated correctly when you installed it?

Edited by NWfront

Share this post


Link to post
Share on other sites
7 hours ago, NWfront said:

Are you sure it's the correct rod for your generation of gun?  Was it possibly not seated correctly when you installed it?

 

I added a few more photos showing the fit in the gun and the length. It's a gen 5. 

 

Jager sent me a dm and is going to make it right. Great customer service!

Share this post


Link to post
Share on other sites
2 hours ago, jerseyglock said:

Can you update on Jager's fix?

 

He is replacing it. He said that he had few gen 5 guide rods go out by mistake without the proper hardening.

Share this post


Link to post
Share on other sites

I had the same thing happen to two of my guide rods. Jager exchanged both of my guide rods and all is good.  Great customer service ! 

Share this post


Link to post
Share on other sites

Hey guys,

 

Looks like I goofed up. somehow some of my Gen. 5 rods (either G17G5CS or G17G5CSH) slipped through without the proper heat treat. Some, not all. You'll know immediately if all the color comes off. My greatest apologies, and I'll replace them if you were unlucky enough to get one of these from me. Just ship it back, and I'll include a recoil spring of your choice to cover the shipping back. Sorry...….

 

Thanks, Jager

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...