Jump to content
Brian Enos's Forums... Maku mozo!
Balakay

2011 Mag tuning question

Recommended Posts

I have 2 2011's with identical PT steel grips

Gun 1 has extended magazine release

MBX and STI gen 1 no problems

STI gen 2 wont drop an empty mag but no issues with 1 or more rounds left in the magazine

 

Gun 2 has non-extended release

MBX, STI gen 1 and 2 drop free

 

All mags have Grams guts and springs have low mileage.

 

Is this due to the different mag release? Not really understanding this...

Share this post


Link to post
Share on other sites

Have you tried swapping the mag release over from one gun to the other and see if the problem follows the mag release or stays with the gun?

Sent from my SM-G975U using Tapatalk

Share this post


Link to post
Share on other sites

Mag catch heights vary.  Try conditioning the springs in your Gen 2 mags.  Fully load them and let them sit for two weeks.  The spring will take a set and work fine.  Also check to see that the followers are not too canted.  I had a little trouble with mine do I swapped out the spring and follower for TTI.

Share this post


Link to post
Share on other sites

Put the mag in that sticks, while it is sticking barely release pressure on the mag release and see if the mag falls, if it does

you are pinching the mag with the release. you will need to file the mag release a little to clear the mag.

Share this post


Link to post
Share on other sites
Posted (edited)

The follower could be catching on the slide release. Shave a little off. 

Chances are this is it if it only has the issue with no rounds in it. 

 

Take the spring/follower out and see if it works. If so, follower needs to be trimmed. 

Edited by echotango

Share this post


Link to post
Share on other sites
3 minutes ago, sauza45 said:

Put the mag in that sticks, while it is sticking barely release pressure on the mag release and see if the mag falls, if it does

you are pinching the mag with the release. you will need to file the mag release a little to clear the mag.

 I tried this. It does not fall. However, when I put the original STI springs and followers in, it drops perfectly 

 

As suggested above, I tried swapping the magazine releases between the two groups. Even though they are both PT evo grips, the magazine releases do not fit in the opposite grip...strange 

 

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, echotango said:

The follower could be catching on the slide release. Shave a little off. 

Chances are this is it if it only has the issue with no rounds in it. 

 

Take the spring/follower out and see if it works. If so, follower needs to be trimmed. 

I think this might be the answer because the STI followers work. The grams do not

Share this post


Link to post
Share on other sites

shave the follower tip down that hangs on the slide realease so that  it does not catch on the slide release, ..Atlas has many vids on youtube regarding these mag mods 

Share this post


Link to post
Share on other sites
5 hours ago, Furrly said:

shave the follower tip down that hangs on the slide realease so that  it does not catch on the slide release, ..Atlas has many vids on youtube regarding these mag mods 

Done.  Problem solved. Thanks to all who offered suggestions

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...