Jump to content
Brian Enos's Forums... Maku mozo!

grayguns 320 comp trigger kit


m700
 Share

Recommended Posts

Is it mandatory to complete the voluntary upgrade  in order to install this kit? I havent had the chance to check my serial yet but im pretty sure i bought just before this process started.

Link to comment
Share on other sites

Thats what I was afraid of. Now I have to get home and get me serial number in to check it. I was searching for the trigger kit for 2 weeks I wish i would have noticed then.

Link to comment
Share on other sites

It'll fit.  Leave the overtravel stop out. Old guns need overtravel to reset.  

 

If you have an x5 Im pretty sure You'll be left with an over seas version of the upgrade minus the lifter which is lighter on the new guns. Ive had both and pulled them down to compare parts. 

 

Australians dont get the slide disconnect if they upgrade and grayguns said it would be fine.

 

Of course noone official will confirm exactly what goes into an upgrade here but it is parts only and no machining.  

 

X5s have the skeletonised striker, regular 320s  dont which is why I say this for x5s only.  

 

Ymmv. Use at your own risk.  Etc. 

 

Link to comment
Share on other sites

Found out I do need upgrade. I'm sending it today they say 2-3 weeks. I also asked if they had x5 legion grips available he said he's taking orders so I said count me in. $269

Sent from my Pixel 2 XL using Tapatalk

Link to comment
Share on other sites

On 7/3/2019 at 11:21 AM, m700 said:

Found out I do need upgrade. I'm sending it today they say 2-3 weeks. I also asked if they had x5 legion grips available he said he's taking orders so I said count me in. $269

Sent from my Pixel 2 XL using Tapatalk
 

 

How do I order a Legion grip for $269.00?

Link to comment
Share on other sites

When I called stuff about voluntary upgrade I asked about it he said they aren't shipping yet but if I add myself to preorder list I can get it for 269. He said I wouldn't be charged to it ships and I'm pretty sure it charged yesterday.

Sent from my Pixel 2 XL using Tapatalk

Link to comment
Share on other sites

  • 3 weeks later...

The voluntary upgrade does involve machining.  A V notch with a rounded bottom is machined into the right rear of the underside of the slide. It mates with the new safety button/lever now installed in the sear housing. 

Link to comment
Share on other sites

I have had mine installed for a couple of months now and last Sat. at a match I was shooting in a friend brought his new X5. After the shoot we were comparing his to mine and I got out my Wheeler trigger gauge and tested his stock, and mine with the GG kit. His came in on a ten pull average just over 5 pounds, Mine was a little under 3 pounds with less travel and a quicker reset.

 

I have not done any polishing, just installed and lubed with Lucas 

Link to comment
Share on other sites

On 7/24/2019 at 5:57 PM, LawDog324 said:

I have had mine installed for a couple of months now and last Sat. at a match I was shooting in a friend brought his new X5. After the shoot we were comparing his to mine and I got out my Wheeler trigger gauge and tested his stock, and mine with the GG kit. His came in on a ten pull average just over 5 pounds, Mine was a little under 3 pounds with less travel and a quicker reset.

 

I have not done any polishing, just installed and lubed with Lucas 

 

Very similar to my experience. Stock a little over 5. GG right about 2.75/2.80.

Link to comment
Share on other sites

Anyone have the issue with this kit that you cannot dry-fire but If you throw a loaded mag in the gun functions fine? A lot of things happened at once I got the gun back from voluntary upgrade and installed this kit. Im not a smith so i could have screwed something up but everything looked OK

Link to comment
Share on other sites

I don't have any problems dry firing with no mag in the gun.

 

Although, I took my gun apart at a safe table on Saturday though after a jam (ammo related) and when I first put the slide back on, it wouldn't reset the striker - just had a springy trigger. I removed and reinstalled the slide again and it was fine. Someone in my squad mentioned this happens with 320s occasionally -- not sure the truth on that as it was the first time I'd ever experienced it.

Link to comment
Share on other sites

I've had a somewhat similar experience.

 

I've installed two kits in two X5s. 

 

The first kit installed with no drama.

 

The second kit would not set the seer after cycling the slide.

 

I emailed Bruce and he suspected parts on the edge of tolerance and to send the kit back if the situation did not resolve.

 

I detail stripped the FCU, cleaned it up, lubed, (all of which I had done prior to the first installation), and re-installed the kit.

 

No further issues.

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...