Jump to content
Brian Enos's Forums... Maku mozo!
nick779

MOS Plate torque

Recommended Posts

What are you guys torquing your MOS adapter plates to and what thread locker?

 

Best ive found is 15 inch pounds with either 243 or Vibratite from another forum.

Share this post


Link to post
Share on other sites

Don't the instructions say hand tight?  

 

If you have new screws, they come with loctite on them. If I was re-installing a dot, I'd clean the old ones and use blue. 

Share this post


Link to post
Share on other sites
46 minutes ago, B_RAD said:

Don't the instructions say hand tight?  

 

If you have new screws, they come with loctite on them. If I was re-installing a dot, I'd clean the old ones and use blue. 

 

It does in fact say had tight, I didnt realize there was a booklet under the mos plates. 

 

Still though, hand tight means different things to different people. Im going to guess at 10-15 inch pounds I guess.

Share this post


Link to post
Share on other sites

Anyone else have issues with the factory thread locker?  My plate came loose this weekend and it didn't appear to bond to the slide very well despite me degreasing it before installation.   I thought maybe I missed some so after cleaning it up I used a second set from a new package to give it another try.  If they back out a second time I'll try Loctite 242.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, NWfront said:

Anyone else have issues with the factory thread locker?  My plate came loose this weekend and it didn't appear to bond to the slide very well despite me degreasing it before installation.   I thought maybe I missed some so after cleaning it up I used a second set from a new package to give it another try.  If they back out a second time I'll try Loctite 242.

I've had 4 MOS Glocks. I've only had one work lose. 

 

I didn't degrease any before installing. Just used the factory loctite. I suspect I didn't torque it down enough. Always worried about over torque when something calls for "hand tight".

 

I've reinstalled it and have about 600 rnds on it now. I did degrease and reapplied loctite. 

Edited by B_RAD

Share this post


Link to post
Share on other sites

I torque to 12 inch pounds.  I just used blue thread locker

Share this post


Link to post
Share on other sites

FWIW I degreased, applied some 243 blue and torqued incrementally down to 15 inch pounds. Still solid and holding zero at 1400rds. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...