Jump to content
Brian Enos's Forums... Maku mozo!

Canik TP9 SFX - Weak Ejecting Magazines


Recommended Posts

I googled and looked around the forum. I've never had any issues with magazines not ejecting until recently. I've cleaned the magazines and the magwell so that its clean enough I cant get any debris on my finger. 
some magazines might eject a little better than others, but not by much. Besides the spring in the magazine assisting ejection is there any other spring I should look at? Or is it maybe that my polymer gun's magwell has been beat up from magazine changes and has burrs in it or something? I mean I can feel some resistance near the bottom, but I look in it and t doesn't look to bad. 

 

Thanks for the help! 

Link to comment
Share on other sites

44 minutes ago, PlayFront36 said:

I noticed the same issues when handling the TP9SF Elite at the gun shop.  My cousin owns a TP9SFx and swears his magazines drop free.  Seems intermittent.

 

mine used to drop awesome. No issues. Its like there was a rocket pushing them out... Now I have to pull half of them.... 
 

Link to comment
Share on other sites

54 minutes ago, Dan Sierpina said:

No springs, gravity does it. Hold the gun in a vertical  orientation when you make a reload. If that's not helping, look to see where the magazine tube is dragging in the frame.

gravity... great... its also the thing I hate when I step my fat a$$ on a scale... hehe 

 

Thanks for the answer though!

 

I read a post that talked about taking really fine grit sand paper and making the entire mag well about a couple thousands bigger... thoughts? 

Link to comment
Share on other sites

22 minutes ago, shakin_bakin said:

 

mine used to drop awesome. No issues. Its like there was a rocket pushing them out... Now I have to pull half of them.... 
 

That sounds like weakening magazine springs to me.  

 

If all we did was drop full magazines they would work great!

Link to comment
Share on other sites

20 minutes ago, shakin_bakin said:

umm do they go bad in less than a year? I mean I do shoot like 1500 rounds a month. But they only get loaded to like 8 rounds at a time and I have 6 magazines I rotate through. 

Springs wear when cycled.  Whether you load them to 15rd or 5 or 10.  Shooting 18,000 rounds a year sure sounds like it could do it...

Link to comment
Share on other sites

10 hours ago, PlayFront36 said:

Springs wear when cycled.  Whether you load them to 15rd or 5 or 10.  Shooting 18,000 rounds a year sure sounds like it could do it...

I actually have a backup gun that has less than 200 rounds through it, I'll try them in that one as its only been shot once.
Secondly, I also have about 4 brand new magazines I can try to use just to seperate rather its a gun issue or a magazine issue.

Link to comment
Share on other sites

9 hours ago, highhope said:

it sounds like the follower stucks...  

Like the follower inside the magazine? I took the mags apart, cleaned them, and put them back together hoping that was the case. Didnt do anything.

I will say, it is kind of interesting how the mags are all starting to go bad at a similar time. I do rotate between the same six mags.

Link to comment
Share on other sites

Buy an extended or “plus 10%” spring for the Walther (easier to find parts for) and see if it helps.

 

If it does, buy more.

 

And personally, I’d absolutely wrap some sandpaper around a length of 1x2 and try to open up the grip a few thousandths and/or remove any burrs it might happen to find.

Edited by MemphisMechanic
Link to comment
Share on other sites

20 hours ago, MemphisMechanic said:

Buy an extended or “plus 10%” spring for the Walther (easier to find parts for) and see if it helps.

 

If it does, buy more.

 

And personally, I’d absolutely wrap some sandpaper around a length of 1x2 and try to open up the grip a few thousandths and/or remove any burrs it might happen to find.

 

I used my backup gun and all the mags ejected fine. But new mags ejected like a rocket out of my backup gun and not so great out of my competition gun. So I knew it was the gun.

 

I lightly sanded but used my finger to just clean up the spots I can see are roughed up from jamming mags in and out. The mags eject with no issues again.

 

thanks for the help! 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...