Jump to content
Brian Enos's Forums... Maku mozo!
Joec08

CZ SP-01 Shadow Custom

Recommended Posts

I have A CZ SP01 custom  that in the middle of the stage will stop firing. The hammer is cocked and back but when I pull the trigger nothing happens.  It will fire when I draw and pull the trigger in double action but then in the middle of the stage will stop firing.  Any ideas ?

Share this post


Link to post
Share on other sites

Not to state the obvious but are you bumping the safety up accidentally? (I have a tactical with safety, assuming the custom doesn’t have a decocker) 

Share this post


Link to post
Share on other sites

The gun does not reset for next single-action cycle? Check trigger bar is making it way back and up to re-engage with sear. Is it dirty? Trigger bar spring looks good?

Please search the forum, it has been covered multiple times.

If thats a new gun without history of errand gunsmithing I would send it back to seller to make it right (after cleaning it).

 

You've got a reply in another thread about disconnector wings interfering. Before taking a file to it I would check for more obvious issues.

Here are the pictures for both SA and DA: https://photos.app.goo.gl/bLRqL1aKPnHzFsHY8

Share this post


Link to post
Share on other sites

I had that happen, just turned out to be dirty as hell.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...