Jump to content
Brian Enos's Forums... Maku mozo!
mike NM

Walther new steel frame competition Q5

Recommended Posts

Xav91, I'm having FTE as well, shows up every 100-150 rounds as double feed with empty case loose in the chamber.  Have the same loose mags pushing to left, same witness mark on slide, but no noticeable mark on mags.  Not clear to me how the slide interference would cause my double feed, but certainly can see that it could interfere with cycling forward, which is a critical step with this pistol needing to cock the striker spring at the end of forward movement.   To try to fix the failures to extract before seeing your post, I increased tension on the extractor, noticed it was straight, while the same part on PPQ M2 had a little curve along the tail.  Added a slight curve.  No further issue seen in next 500 rounds.  Testing tension by having extractor hold onto a round seemed to be fine before adjustment, however.  Was just about to send it back to Walther.  

 

Looking at my CZ SP-01 Shadow Custom, would note it had various surfaces rounded down from factory by the custom shop to improve function.   Looking the same place as the witness mark, both corners of that portion of the slide are ground down much more than you are showing from either the shop or usage.  Only a slight amount of wiggle play in the CZ mags.

Share this post


Link to post
Share on other sites
On 2/3/2019 at 10:23 PM, MemphisMechanic said:

 

Yes. That’s what I’ve been running. A tight 23(+1, if needed) to start, and 22 easily reloadable. You’ll have to grind the tab off the follower that locks the gun open but it works great otherwise.

 

There’s a recipe I was just turned on to by another shooter which uses a Canik mag tube and apparently gets you a reloadable 23. I haven’t tried it, and don’t know how “reloadable” it is.

 

23 in a Walther/TTI/Grahams320 recipe is reloadable, if you drive it in hard and distract yourself from the stage plan to ensure that it’s seated. With 22 in them the click into place as easily as a factory mag.

 

The recipe suggested is below. I’m 125fmj, and he hasn’t returned to answer my questions yet:

 

AA270CAC-0C46-40C4-BEE5-8B2BF8434FB4.thumb.jpeg.d4b497029b3d0db6807bcc2a2d39d451.jpeg

 

Share this post


Link to post
Share on other sites

I have the q5 sf and bought the tti base pads +5 also bought Graham’s springs and follower and I cut off the tab for lock back and 2 out of the 3 mags only load 19 rounds and 1 of them loads 22. Any ideas I measured the base pads they are all the same?  The springs are the same 11 coil. Probably something simple but I can’t figure it out?

Share this post


Link to post
Share on other sites

Has anyone measured a TTI base pad combo in a mag gauge? 

Share this post


Link to post
Share on other sites
2 hours ago, dfox said:

I have the q5 sf and bought the tti base pads +5 also bought Graham’s springs and follower and I cut off the tab for lock back and 2 out of the 3 mags only load 19 rounds and 1 of them loads 22. Any ideas I measured the base pads they are all the same?  The springs are the same 11 coil. Probably something simple but I can’t figure it out?

 

I haven’t heard of this one. At 19 that means the follower is not coming down into the extension.

 

Try smacking the baspad really hard on a table at 18-19, seeing if things shift. That’s common for 2011 Limited shooters to do at first.

 

I know at least 4 guys running the TTI & Grams P320 combo and we’ve all gotten 23 from the very first try.

 

Share this post


Link to post
Share on other sites

My Pro model just came in today, so that tells me the April batch is now here!

 

Mine doesn’t seem to have the extreme magazine side to side play on initial inspection, but its also still a virgin.  Will get some rounds downrange with it tomorrow.  

 

TTI +5 baseplates just barely fit with the Pro magwell (on a PPQ M2 mag body and follower for 20 total). 

Share this post


Link to post
Share on other sites
Posted (edited)

Does anyone know if the new shipment of Steel Frames will include some with the new adjustable triggers already installed?  Anyone hear of an eta?

Edited by JL175
Typo

Share this post


Link to post
Share on other sites
On 3/22/2019 at 6:09 AM, Zmaniac said:

Xav91, I'm having FTE as well, shows up every 100-150 rounds as double feed with empty case loose in the chamber.  Have the same loose mags pushing to left, same witness mark on slide, but no noticeable mark on mags.  Not clear to me how the slide interference would cause my double feed, but certainly can see that it could interfere with cycling forward, which is a critical step with this pistol needing to cock the striker spring at the end of forward movement.   To try to fix the failures to extract before seeing your post, I increased tension on the extractor, noticed it was straight, while the same part on PPQ M2 had a little curve along the tail.  Added a slight curve.  No further issue seen in next 500 rounds.  Testing tension by having extractor hold onto a round seemed to be fine before adjustment, however.  Was just about to send it back to Walther.  

 

Looking at my CZ SP-01 Shadow Custom, would note it had various surfaces rounded down from factory by the custom shop to improve function.   Looking the same place as the witness mark, both corners of that portion of the slide are ground down much more than you are showing from either the shop or usage.  Only a slight amount of wiggle play in the CZ mags.

Thank you for the info. I haven't shot the gun again and still have not send it to walther. I have a big match this weekend, so I ended up redrawing the plastic guides (thicker) and I'm having them printed. I should have them tomorrow. That should solve the wiggle problem...

Share this post


Link to post
Share on other sites
Posted (edited)

Let me know how that works and where I can buy some of them.

Edited by dfox

Share this post


Link to post
Share on other sites
23 hours ago, Xav91 said:

Thank you for the info. I haven't shot the gun again and still have not send it to walther. I have a big match this weekend, so I ended up redrawing the plastic guides (thicker) and I'm having them printed. I should have them tomorrow. That should solve the wiggle problem...

If that works will you share the .stl file for those of us with printers?

Share this post


Link to post
Share on other sites

Went up to the range and shot the gun again. Only used the mags that came with the gun. No issues. Extra Walther PPQ mags no bueno. ??????

Share this post


Link to post
Share on other sites

I ended up redrawing the plastic guides (thicker) and I'm having them printed. I should have them tomorrow. That should solve the wiggle problem...

 

If that works, you have a new business, let us know.

Share this post


Link to post
Share on other sites
On 3/25/2019 at 6:57 AM, dfox said:

I have the q5 sf and bought the tti base pads +5 also bought Graham’s springs and follower and I cut off the tab for lock back and 2 out of the 3 mags only load 19 rounds and 1 of them loads 22. Any ideas I measured the base pads they are all the same?  The springs are the same 11 coil. Probably something simple but I can’t figure it out?

 

Make sure the bottom of your spring doesn't get kinked and flipped over when you put your base pads on. This has happened to me a couple times with my P320 mags using Grams spring and follower kits, always made it so I could only get 18 rounds into the magazine when it should be 23 when done correctly. You just have to tinker around with it to make sure everything assembles correctly

Share this post


Link to post
Share on other sites
9 minutes ago, thx1138jt said:

@Xav91

 

Wondering how your new plastic guides worked out. Did it solve the issue?

Yes I believe I did, but I need  few more days to be sure. I had to do a little fitting out of the first set. Mag aligns perfectly. I left enough play they can go in and out easily. Shot 250 rds at practice without any issue so I took it to shoot a sanctioned IDPA match this past weekend. The gun ran perfectly well. 

I have been traveling since so I have not taken the gun down to clean and inspect it, but I will and post an update once I'm back home. So prior to inspection, i think the functionality issue is solved.

Share this post


Link to post
Share on other sites

Awesome!  Thanks for the reply. Looking forward to your update. 

Share this post


Link to post
Share on other sites

Has anyone checked their TTI basepads on a mag gauge? I heard that they are slightly oversized on the Canik and Glock setups.

Share this post


Link to post
Share on other sites

Can anyone post a picture of their Grams P320 follower modified with the tab ground down?   Thanks in advance.

Share this post


Link to post
Share on other sites
1 hour ago, jojima said:

Can anyone post a picture of their Grams P320 follower modified with the tab ground down?   Thanks in advance.

Just cut or sand off the tab so that you have straight plastic down the side of the follower. Extremely simple.

 

It just needs to avoid contact with the inside of the gun when an empty mag is inserted. Stick it in, and you’ll see what to shave off.

Share this post


Link to post
Share on other sites

I see where USPSA added it fully to the production list yesterday (no longer just CO only):

 

image.thumb.png.d61405649f888cccc8d613a15d02ff85.png

Share this post


Link to post
Share on other sites
33 minutes ago, tombo131 said:

I see where USPSA added it fully to the production list yesterday (no longer just CO only):

 

image.thumb.png.d61405649f888cccc8d613a15d02ff85.png

Good deal, I knew it would right after shot a level 2 haha

Share this post


Link to post
Share on other sites
On 4/4/2019 at 12:01 AM, Xav91 said:

Yes I believe I did, but I need  few more days to be sure. I had to do a little fitting out of the first set. Mag aligns perfectly. I left enough play they can go in and out easily. Shot 250 rds at practice without any issue so I took it to shoot a sanctioned IDPA match this past weekend. The gun ran perfectly well. 

I have been traveling since so I have not taken the gun down to clean and inspect it, but I will and post an update once I'm back home. So prior to inspection, i think the functionality issue is solved.

So, little update. Yes, the new guides fixed the lineup issue. However, there was definitely more going on. I ended up sending it back to walther last week. 

I let you know what's the diagnosis and what they fix...

Share this post


Link to post
Share on other sites
12 hours ago, Xav91 said:

So, little update. Yes, the new guides fixed the lineup issue. However, there was definitely more going on. I ended up sending it back to walther last week. 

I let you know what's the diagnosis and what they fix...

Did you ever try change in guide rod/spring weight? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...