Jump to content
Brian Enos's Forums... Maku mozo!
Rudukai13

RIA VR80 coming in 2019

Recommended Posts

Problems Hand Cycling

 My gun doesn't want to hand cycle rounds. I have 3-400 rounds thru the gun. It will cycle 1200fps shells without issue. I took it apart and cleaned it getting ready for a match Saturday and tried to hand cycle rounds after cleaning and found that the rounds get stuck as they are going into the chamber at about a 45deg angle. If I pull the bolt back slightly the round will pop up and chamber. This is not magazine specific as I tried several mags. I have checked the feed lip dimensions on all the mags and they are the same. I have polished the feed lips on the mags.

Any ideas?

Share this post


Link to post
Share on other sites
Problems Hand Cycling
 My gun doesn't want to hand cycle rounds. I have 3-400 rounds thru the gun. It will cycle 1200fps shells without issue. I took it apart and cleaned it getting ready for a match Saturday and tried to hand cycle rounds after cleaning and found that the rounds get stuck as they are going into the chamber at about a 45deg angle. If I pull the bolt back slightly the round will pop up and chamber. This is not magazine specific as I tried several mags. I have checked the feed lip dimensions on all the mags and they are the same. I have polished the feed lips on the mags.
Any ideas?
Does it work under firing conditions ... If so, who cares

Sent from my SM-G975U using Tapatalk

Share this post


Link to post
Share on other sites
39 minutes ago, IntenseImage said:

Does it work under firing conditions ... If so, who cares

Sent from my SM-G975U using Tapatalk
 

I agree.  I just thought it was odd. 

Share this post


Link to post
Share on other sites
44 minutes ago, IntenseImage said:

 

 


Sent from my SM-G975U using Tapatalk
 

 

Do they increase capacity

Share this post


Link to post
Share on other sites
Do they increase capacity
Yes, a modded factory 9rd holds 10 so I expected 11 but it took 12 and the factory 19 now holds 20

Sent from my SM-G975U using Tapatalk

Share this post


Link to post
Share on other sites
39 minutes ago, hump said:

I agree.  I just thought it was odd. 

Is it all rounds in the mag or just the first? Or are you leaving rounds in the mag for any amount of time before you try this...say couple hours or anything where the first round gets distorted? I’ve found some odd things about this gun when not firing it but it seems like it runs fine under live fire

Share this post


Link to post
Share on other sites
2 hours ago, WWG1WGA said:

Is it all rounds in the mag or just the first? Or are you leaving rounds in the mag for any amount of time before you try this...say couple hours or anything where the first round gets distorted? I’ve found some odd things about this gun when not firing it but it seems like it runs fine under live fire

Most of the first 8-10 rounds. They were loaded in the mag just before I cycled it. 

Share this post


Link to post
Share on other sites
1 hour ago, hump said:

Most of the first 8-10 rounds. They were loaded in the mag just before I cycled it. 

I think it’s just one of those quirks with this quirky rifle. I had a lot of shells get jammed in the chamber after firing. Those were a bitch to get out. My bolt release is still ridiculous to release. So much so that I may extend it or just do away with the lock back on empty and just charge with a new mag if it doesn’t “work itself out”. Ive had some other small issues but it seems to get better on its own the more I work the gun. Time will tell

Share this post


Link to post
Share on other sites
6 hours ago, hump said:

Problems Hand Cycling

 My gun doesn't want to hand cycle rounds. I have 3-400 rounds thru the gun. It will cycle 1200fps shells without issue. I took it apart and cleaned it getting ready for a match Saturday and tried to hand cycle rounds after cleaning and found that the rounds get stuck as they are going into the chamber at about a 45deg angle. If I pull the bolt back slightly the round will pop up and chamber. This is not magazine specific as I tried several mags. I have checked the feed lip dimensions on all the mags and they are the same. I have polished the feed lips on the mags.

Any ideas?

Mine would occasionally hang up like that.  I sanded off the anodizing and polished the feed ramp in the lower receiver.  This seems to have fixed it.  

 

Might check the extractor notch in the barrel.  Mine was very sharp and would cut the plastic near the end of the shell.  Where it folds over to form the crimp.  I don’t think it was causing the malfunction, but i “smoothed” it up anyway.

 

finally, I noticed it seems to run best with lots of oil.  

Share this post


Link to post
Share on other sites
11 hours ago, WWG1WGA said:

Got my RIA Magnum condom heat shield installed today! 

1CD5D856-FAA1-485F-B021-71151C913826.jpeg

Ribbed...for your pleasure!!  ha ha ha ha 

Share this post


Link to post
Share on other sites
On 5/7/2019 at 11:31 AM, WWG1WGA said:

I ordered the spring kit for like $15. I think it said 4.5 lbs

Is it a JP spring kit? Where did you get it?

Share this post


Link to post
Share on other sites
1 hour ago, IHMSA15151 said:

Is it a JP spring kit? Where did you get it?

Yes. I got it on eBay. 

Share this post


Link to post
Share on other sites
On 5/7/2019 at 3:27 PM, IntenseImage said:

Nice so you chopped off the vert ports because of barrel ports?

Sent from my SM-G975U using Tapatalk
 

Yes

Share this post


Link to post
Share on other sites
20 hours ago, busdriver said:

Mine would occasionally hang up like that.  I sanded off the anodizing and polished the feed ramp in the lower receiver.  This seems to have fixed it.  

 

Might check the extractor notch in the barrel.  Mine was very sharp and would cut the plastic near the end of the shell.  Where it folds over to form the crimp.  I don’t think it was causing the malfunction, but i “smoothed” it up anyway.

 

finally, I noticed it seems to run best with lots of oil.  

I think I found my problem. The forward legs on the bolt carrier were rubbing the magazine. I measured the carrier legs and found the very front of the leg was .038 narrower than the rear section. I adjusted this and it is now much smoother. I won't get to test it before the match on Saturday but it feels "right" now.

Share this post


Link to post
Share on other sites
On 5/8/2019 at 12:29 AM, Firebull said:

Can anyone share how you remove the trigger and hammer pins? Thanks.

If you are still looking for this answer, the come out from opposite sides. So the one with the circlip is obvious, the other pin comes out the other way. Does that make sense? 

Share this post


Link to post
Share on other sites
9 hours ago, IHMSA15151 said:

Is it a JP spring kit? Where did you get it?

Ok so just did the spring kit. You can only use the yellow trigger spring. The red hammer spring won’t fit right. Anyhow, I tried getting a stock pull weight before I started but my gauge goes from 8 lbs to “holy s#!t that’s heavy”. So who knows how high it was to start with. After the jp spring it’s right at 7lbs. So it’s not a jewel trigger but it’s better for $15

Share this post


Link to post
Share on other sites
12 hours ago, WWG1WGA said:

Ok so just did the spring kit. You can only use the yellow trigger spring. The red hammer spring won’t fit right. Anyhow, I tried getting a stock pull weight before I started but my gauge goes from 8 lbs to “holy s#!t that’s heavy”. So who knows how high it was to start with. After the jp spring it’s right at 7lbs. So it’s not a jewel trigger but it’s better for $15

Thanks for the info, I think I have a JP spring set in my junk box. I'll give it a try. The complete trigger sets are $120 and out of stock, so if this helps a little that would be great.

Share this post


Link to post
Share on other sites
13 hours ago, WWG1WGA said:

If you are still looking for this answer, the come out from opposite sides. So the one with the circlip is obvious, the other pin comes out the other way. Does that make sense? 

Thank you!

Share this post


Link to post
Share on other sites
On 5/8/2019 at 6:50 PM, IntenseImage said:

Yes, a modded factory 9rd holds 10 so I expected 11 but it took 12 and the factory 19 now holds 20

Sent from my SM-G975U using Tapatalk
 

Where did you get the magazine baseplates? 

....could i fit one onto the 29 round mag and actually start a round with 30 in the mag??

Share this post


Link to post
Share on other sites
Where did you get the magazine baseplates? 
....could i fit one onto the 29 round mag and actually start a round with 30 in the mag??
Armanov.com ... I don't see why you couldn't but the mag holds 28 out of the box so would be 29 most likely

Sent from my SM-G975U using Tapatalk

Share this post


Link to post
Share on other sites

Anyone who has modified the mags to fit more rounds...how much of the base did you remove? Is there any reason for not just taking it all off and just using the flat bottom part to lock the base plate into position?  You’d still have the retainer in there just not the post. Does it keep the spring from binding in any way? Any reasons not to? Thanks

Share this post


Link to post
Share on other sites
Anyone who has modified the mags to fit more rounds...how much of the base did you remove? Is there any reason for not just taking it all off and just using the flat bottom part to lock the base plate into position?  You’d still have the retainer in there just not the post. Does it keep the spring from binding in any way? Any reasons not to? Thanks
Cut it flush is fine and the easiest

Sent from my SM-G975U using Tapatalk

Share this post


Link to post
Share on other sites
On 5/12/2019 at 4:47 PM, IntenseImage said:

Cut it flush is fine and the easiest

Sent from my SM-G975U using Tapatalk
 

Anyone cutting mag springs yet?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...