Jump to content
Brian Enos's Forums... Maku mozo!
highhope

case ejected to breech face, 9major jam

Recommended Posts

9major mid open gun. Get jam occasionally because of case be ejected to the breech face. What kind of ejector interface shape could help eject the case to the right? Tested the extractor tension, looks good. Using 8lb ismi recoil spring, (tested 7-9 , same issue) . reddot is dpp, one side mount. Thanks a lot!

Edited by highhope

Share this post


Link to post
Share on other sites

Brazos ejector cured mine. Do make sure you have enough extractor tension though. A well shaped extractor to allow feeding of the next round, but strong enough tension so the next round in the mag does not dislodge it before it hits the ejector.

 

With just a bare slide, a round inserted under the extractor, it takes a healthy thump to dislodge the case.  

Share this post


Link to post
Share on other sites

This is what I do to tune the ejector. 

 

Start off with a new EGW extended ejector (or any extended ejector). Make sure you relieve the bottom of the ejector so a round in the mag and/or the mag does not contact ejector.  I usually use a dremel with a round sanding drum to clearance this.

 

Then I cut/file a 10 degree cut on the ejector face.  With the longest part at the top. So the top of the ejector contacts the case. Then I hand cycle some dummy rounds. Paying attention to ejection group and angle. 

 

After this I the cut/file another 10 degree cut from the top of the ejector face. Moving the contact point down about 1/3 of the way. Then repeat hand cycling, noting the pattern. 

 

Then cut/file down the ejector face down so the contact point is 2/3 of the way down. The hand cycle again! 

 

I will go back and cut the profile that gave me the best/most constant ejection! 

 

You can also do this at the range with live rounds to see what works the best for that gun. 

 

Only remove what is necessary so you don't shorten the ejector too much. And also pay attention to if the ejector is to long and won't properly eject a live round!

 

This has worked well for me on many guns that I have built. And it seems like every gun has a slightly different sweet spot!

Share this post


Link to post
Share on other sites

I had a problem like that 12 years ago with my TruBor -

it turned out the mag was causing the problem.

 

Check to see if the problem occurs with all of your mags

or just one of them.    :) 

Share this post


Link to post
Share on other sites

Check for small burs on the slide as well..could be slide stop, could be safties, or as others said magazines...there are several possible culprits...is the gun a plastic or metal grip?

Share this post


Link to post
Share on other sites
On 8/17/2018 at 2:00 PM, Broncman said:

Brazos ejector cured mine. Do make sure you have enough extractor tension though. A well shaped extractor to allow feeding of the next round, but strong enough tension so the next round in the mag does not dislodge it before it hits the ejector.

 

With just a bare slide, a round inserted under the extractor, it takes a healthy thump to dislodge the case.  

Brazos site will tell you how to tune ejector

Share this post


Link to post
Share on other sites

True... But I got tired of fooling with it. I wanted to shoot matches! It has worked great and the length is different from my other two 9mm ejectors. It is longer.

 

Now if I can fix the nut behind the trigger, the gun has been doing it's part shooting 9 Major.

 

Share this post


Link to post
Share on other sites
11 hours ago, Broncman said:

 

 

Now if I can fix the nut behind the trigger , the gun has been doing it's part shooting 9 Major.

 

 

That's why we're all here - to try to fix the nut    :) 

Share this post


Link to post
Share on other sites
On 8/17/2018 at 2:01 PM, 36873687 said:

Was having these. Replaced the aftec 1k no issues 

 

Nice

Edited by metricgoods

Share this post


Link to post
Share on other sites
On 8/17/2018 at 1:51 PM, rishii said:

What scope and mount are you running

 

 

Thanks, I am using DPP and one side mount.

 

On 8/17/2018 at 2:00 PM, Broncman said:

Brazos ejector cured mine. Do make sure you have enough extractor tension though. A well shaped extractor to allow feeding of the next round, but strong enough tension so the next round in the mag does not dislodge it before it hits the ejector.

 

With just a bare slide, a round inserted under the extractor, it takes a healthy thump to dislodge the case.  

 

On 8/17/2018 at 5:31 PM, Stymie12000 said:

This is what I do to tune the ejector. 

 

Start off with a new EGW extended ejector (or any extended ejector). Make sure you relieve the bottom of the ejector so a round in the mag and/or the mag does not contact ejector.  I usually use a dremel with a round sanding drum to clearance this.

 

Then I cut/file a 10 degree cut on the ejector face.  With the longest part at the top. So the top of the ejector contacts the case. Then I hand cycle some dummy rounds. Paying attention to ejection group and angle. 

 

After this I the cut/file another 10 degree cut from the top of the ejector face. Moving the contact point down about 1/3 of the way. Then repeat hand cycling, noting the pattern. 

 

Then cut/file down the ejector face down so the contact point is 2/3 of the way down. The hand cycle again! 

 

I will go back and cut the profile that gave me the best/most constant ejection! 

 

You can also do this at the range with live rounds to see what works the best for that gun. 

 

Only remove what is necessary so you don't shorten the ejector too much. And also pay attention to if the ejector is to long and won't properly eject a live round!

 

This has worked well for me on many guns that I have built. And it seems like every gun has a slightly different sweet spot!

Thanks a lot, , will try this method.

 

On 8/17/2018 at 2:01 PM, 36873687 said:

Was having these. Replaced the aftec 1k no issues 

Just bought Aftec and try it later, thanks man! 

 

On 8/18/2018 at 10:02 AM, Hi-Power Jack said:

I had a problem like that 12 years ago with my TruBor -

it turned out the mag was causing the problem.

 

Check to see if the problem occurs with all of your mags

or just one of them.    :) 

All of them, not just one mag, thank you sir!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...