Jump to content
Brian Enos's Forums... Maku mozo!
troupe

New Sig MPX ?

Recommended Posts

Anymore news on the updated MPX. I have not noticed and more postings , prices, availability, or pics. 

 

Thanks

Share this post


Link to post

Haven't heard anything more (been on the lookout) as the disappointed owner of two gen2 mpxs (one an sbr) I'm not holding my breath. Reliability doesn't seem to be the name of the game. 

Share this post


Link to post
4 hours ago, Smithcity said:

...gen2 mpx’s... Reliability doesn't seem to be the name of the game. 

 

This is the reason I went with a Guard setup; talked to too many guys who went back to the AR platform after too many broken SIG parts.

Edited by MemphisMechanic

Share this post


Link to post

I have only had a few ejection issues but after visiting ilwt I haven’t had an issue yet. So I’m either lucky or I clean way to much.


Sent from my iPad using Tapatalk

Share this post


Link to post

My MPX was flawless.  I kept it semi clean and lubed (everything lubed) I ran factory ammo 115's.  I don't believe that the MPX can be over lubed, and the ammo had to have enough power. I guess that Sig will be like normal slug mode in getting a product out.

Share this post


Link to post

The MPX craps where it eats, incredibly dirty for a "piston" system. I to am running an ILWT barrel, opened gas port, etc... Recently replaced the extractor spring on my competition rig, I'm regularly having feeding issues with my 133PF loads and factory ammo with stock 32 round mags. The BCG on one of my MPX's separated (there is a pin holding the top portion of the BCG that interacts with the recoil rods / springs to the bottom half), it destroyed the upper, had to send it back to sig. I'm having to clean it every 200 rounds otherwise it is absolutely unreliable (I'm using complete jacketed bullets with VV powder), if the gun is cleaned and lubed, I might not have a malfunction. I've tried putting the OEM barrel back in, still isn't reliable. I've also tried polishing the feed ramps.

 

I've got two rigs, both have had different issues. I also bought them a year apart, both Gen 2's, yet there are several part differences, sig continues to iterate the platform. 

 

Maybe the new variant (Unofficial Gen3?) will have worked out all the issues with the platform. I would exercise caution before purchasing one. I'd want to see lots of consistent positive reviews from folks that really run the gun before I bought one.

Share this post


Link to post

I have been very pleased with mine. It's the softest shooting 9mm carbine I have run. I only have a little over 1200 rounds through it but not a single malfunction. At 600 rounds I pulled the barrel and the gas piston to check it out after reading that they can get really cruddy. All I had to do was brush it off a little and reassemble, I was surprised at how clean it was. I'm running 132 PF loads with 124 Ibejihead coated bullets.

 

I would love to have one of the narrow handguards that they show on the new model but other than that I'm very pleased. I did change out the stock for an AR tube with an ACS stock since the factory I beam stock wouldn't provide a good cheek weld.

Edited by Gregg K

Share this post


Link to post
1 hour ago, Gregg K said:

I have been very pleased with mine. It's the softest shooting 9mm carbine I have run. I only have a little over 1200 rounds through it but not a single malfunction. At 600 rounds I pulled the barrel and the gas piston to check it out after reading that they can get really cruddy. All I had to do was brush it off a little and reassemble, I was surprised at how clean it was. I'm running 132 PF loads with 124 Ibejihead coated bullets.

 

I would love to have one of the narrow handguards that they show on the new model but other than that I'm very pleased. I did change out the stock for an AR tube with an ACS stock since the factory I beam stock wouldn't provide a good cheek weld.

 

Keep shooting it. Mine ran well for the first 3000-5000 rounds. Hope you got lucky and yours continues to work! It sounds like this "Gen 3" might have a different gas system. If they do I hope it is backwards compatible w/ the gen 2's. 

Share this post


Link to post
1 minute ago, Smithcity said:

 

Keep shooting it. Mine ran well for the first 3000-5000 rounds. Hope you got lucky and yours continues to work! It sounds like this "Gen 3" might have a different gas system. If they do I hope it is backwards compatible w/ the gen 2's. 

I hope it does, I need to get more time on it. If it did run to start out with but then quit after 5k rounds I would be suspect of the longevity of the recoil springs. I have heard from others that there have been several different specs for the recoil springs.

Share this post


Link to post

My MPX G2 runs flawless. With factory and my 115/124gr reloads using either N320 and Sport Pistol. 

24c trigger, Holosun, Isler carbon handguard and title II stock.

Shooting it for 8 months now.

All my reloads are JHP so no lead base.

Some of my fellow shooters have had issues- mostly do to them.

Share this post


Link to post

I run Xtreme 115 hp bullets with VV320 behind them, and try to clean/lube about 500 round, and am surprised it runs 100, with as dry and dirty as it gets.

As dirty as it gets, with what should be a clean load, I wouldn't want to go much further without cleaning.

A fellow shooter said he went almost 5k without cleaning, just to see how far he could go. It must have been a PITA to get apart.

Share this post


Link to post

i have been shooting my used Gen2 for the past few months in matches weekly and haven't had a single malfunction , close to 4k rounds.

I clean it after every use " pistons and BCG,  and barrel"  . I use blazer 155 grain bullets and hand loads 147 flat point  Blue Bullets with tight group, i seems to shoot anything i put in it.Even some sub minor 115's

I've been very happy with it, just wish it came with the smaller hand guard

Share this post


Link to post

My gen 1 gun was awesome. Ran it suppressed. Ran it suppressed with a 4.5 barrel. It took it all like a champ. Then it suffered from the cracked carrier issue some of the early guns had and it no run well anymore. I still need to get it out and see what my problem is. 

Share this post


Link to post

My original 2016 gun with 25,000 rounds started with erratic ejection and extraction issues but only under match conditions ... couldn't replicate the stoppage's on the range.. Traced it to a loose ejector  + keep your extractor clean and replace the spring and buffer if it is week..

Share this post


Link to post

Of course it only happened under match conditions!  isn't that a rule or something about malfs???  ?

 

Share this post


Link to post

The MPX s#!t where it eats is incredibly dirty for a “piston” system. Maybe a new version (Unofficial Gen3?) Will work out all the problems with the platform.

Share this post


Link to post
9 hours ago, ravster said:

The MPX s#!t where it eats is incredibly dirty for a “piston” system. Maybe a new version (Unofficial Gen3?) Will work out all the problems with the platform.

Yes, that is what I said on August 7th...

Share this post


Link to post
7 hours ago, Smithcity said:

Yes, that is what I said on August 7th...

He’s just trying to rack up some posts.

 

Anyway, just picked up my new MPX from my FFL yesterday and will be going to the range for some testing today. It’s an 8” barreled pistol bought directly from the Sig Pro shop so I can avail myself of their military discount and free shipping.

 

We’ll see how it goes. I’ll feed it with factory federal 115 Gr ammo first then try my reloads of 124 Gr FMJ with 4.2 Gr Winchester 231. I also ordered a Timney single stage 3 lb trigger made for the MPX from brownells

Share this post


Link to post

wow, I had no idea they have so many issues... mine must be broken because it isn't broken.  Gen 2, only aftermarket trigger and hand guard and it runs 100% Fairly low round count, I am guessing 3k all reloads with fairly low pf.  130ish I have not cleaned it yet but I do lube it. 

Share this post


Link to post
5 hours ago, Paul-the new guy said:

wow, I had no idea they have so many issues... mine must be broken because it isn't broken.  Gen 2, only aftermarket trigger and hand guard and it runs 100% Fairly low round count, I am guessing 3k all reloads with fairly low pf.  130ish I have not cleaned it yet but I do lube it. 

Good luck on getting the piston out. I just can’t imagine how much carbon/gunk is in there.

 I run nothing but jhp bullets, so there’s no exposed lead, in the back(just like my open guns) and run VV powder. I disassemble, and clean/lube at about 500 rounds, and by then, it’s plenty dirty.

Share this post


Link to post

I shot my CMMG Guard last weekend at a 1500 round class.  I'm wondering if I should clean it or see how long it will go without cleaning.

 

Nah!, 1500 rounds is enough.  I'm going to clean it before my match this weekend. ?

Share this post


Link to post
29 minutes ago, RH45 said:

Good luck on getting the piston out. I just can’t imagine how much carbon/gunk is in there.

 I run nothing but jhp bullets, so there’s no exposed lead, in the back(just like my open guns) and run VV powder. I disassemble, and clean/lube at about 500 rounds, and by then, it’s plenty dirty.

 

I don't even know how to get it apart.  Guess I better get on youtube 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...