Jump to content
Brian Enos's Forums... Maku mozo!
Sign in to follow this  
love2fishnshoot

Brand new czechmate issues

Recommended Posts

Went out to fire my brand new czechmate this morning to zero the cmore. Loaded each mag to 10 rds. I noticed they were a little tougher to load rounds into, but figured it was normal since they are new. I just used my trusty uplula.

 

Set up my target at 15 yards. Rack the slide and it doesn’t go all the way into battery. I tap the slide a little and it’s all good. Squeeze the trigger and it goes off like normal. Release the trigger to squeeze again and nothing happens. Look at chamber and the spent case is hanging on top of a new round loosely. Shake the spent case out and chamber another round. Again slide doesn’t go into full battery. This goes on constantly with each of the 4 mags. Sometimes the spent case will eject but every time the slide doesn’t go into full battery. The round seems to be dragging And stopping midway at the feed ramp.

 

i get home and pull the gun apart and start polishing the slide on the wear areas and feed ramps per WD YouTube instructions. Assemble gun again and still have problems with the slide not fully going into battery. I know I will need to ream the barrel, but what else do I need to have done to make it 100% reliable? 

 

Below is a pic of a new magazine loaded and trying to chamber the first round and a plunk test that failed with freedom New ammo, wwb, and blazer brass. All same results 

1AA02255-3DF5-4531-BA65-86A0BBF9A42A.jpeg

FE878AA6-44DD-4FFE-8362-DEDC4FC5A8EE.jpeg

Share this post


Link to post
Share on other sites

Unless that round is jammed in the barrel and won’t come out then that’s a pass.

If it’s “minor” ammo then it may not eject with the factory recoil spring. Change to a 10lb at least.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Does that round rotate freely and drop out of the barrel when you did the plunk test? If not, then the rounds are too long and failed the plunk test. I just got my Czech mate and I didn’t have any problems with it. Granted I shoot my reloads with an OAL of 1.102” which I also shoot in my shadow 2 and TSO.  I also cleaned and lubricated the cm prior to my first range session.

 

heres mine when I was swapping around the  cmore and CZC mounts to check if they fit the TSO and vice versa in which the did.

 

6_E921516-_A537-4_C9_A-8_C70-3_C3_B5665_

 

 

Share this post


Link to post
Share on other sites

Do y’all think it’s a mag problem then? I sent an email to grams engineering last night about getting them tuned. May go ahead and order the czc spring and followers while I’m at it

Share this post


Link to post
Share on other sites

It’s most likely the mags then. Have you tried shooting with the stock mag configuration at all? How about trying that first?

Share this post


Link to post
Share on other sites

Everything is stock. When i insert a new mag and go to chamber a round the slide doesn’t go all the way forward. That’s me pulling the charging handle and releasing. I have to tap the back of slide really good and then it will chamber a round 

Share this post


Link to post
Share on other sites

Ok. Does it feel hard to rack compared to a gun that runs fine?

It might just be fit right (which is a good thing). My TSO was for so tight that it wouldn’t go back into battery like yours. Function fine but was running major with a heavy spring.

It would be worth putting a lighter spring in and seeing if it will run.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Yea. It does take some effort racking the slide. It’s a little easier now that I took some 1200 and 2000 grit sandpaper to the wear areas and put oil everywhere. Still having trouble with manually chambering the rounds though. I have 10 lb and 11 lb spring on the way

Share this post


Link to post
Share on other sites

When I had that problem with mine it was because my loads were to long. I could only run them at 1.140 reliably. I had to get a 9mm throat reamer to get it to not want to hold onto the rounds when ejecting them, or running them a little longer.

Share this post


Link to post
Share on other sites

Don’t think I have a chamber problem. It seems like the mag lips are too tight and dragging the case causing it to hang. The bullet can’t even make it to the chamber before stopping. It stops about midway to 3/4 way up the feed ramp. I’m gonna try and do a little more polishing on the slide and ramp and just sit there for an hour racking the slide. 

 

Does anyone happen to know the measurements for the mag feed lips? I may try and open them up just a tad 

Share this post


Link to post
Share on other sites

I just measured mine that were tuned by grams awhile ago.  Front at tightest spot measures .357 and very back measures .380

 

What is your OAL length?  If it is 2 long it can do a couple of things that cause problems....  1 is drag in the magazine so it does not start to point upward when it comes to the top of the magazine and hits the ramp and cannot slide up it because of the angle it hits it or it may not even come all the way up in the tube at all.  Also if it is to long it can turn your mags into "salt and pepper shakers"......

Share this post


Link to post
Share on other sites
Does that round rotate freely and drop out of the barrel when you did the plunk test? If not, then the rounds are too long and failed the plunk test. I just got my Czech mate and I didn’t have any problems with it. Granted I shoot my reloads with an OAL of 1.102” which I also shoot in my shadow 2 and TSO.  I also cleaned and lubricated the cm prior to my first range session.
 
heres mine when I was swapping around the  cmore and CZC mounts to check if they fit the TSO and vice versa in which the did.
 
6_E921516-_A537-4_C9_A-8_C70-3_C3_B5665_B940.jpg
 
 

Wow. That pretty short, but I bet you never have any problems running that. How much powder do you use?

Also with my CZ and my DVC not only was it not throated enough it didn’t like certain bullet profiles. I opened the STI up because I did not want to only be able to shoot certain Bullets. I wanted to have a choice. Most open shooters run a length of 1.160 to 1.170, but in a CZ its a different story. I found it was 1.135 to 1.145 at the most.

Share this post


Link to post
Share on other sites
33 minutes ago, kitestir said:

I just measured mine that were tuned by grams awhile ago.  Front at tightest spot measures .357 and very back measures .380

 

What is your OAL length?  If it is 2 long it can do a couple of things that cause problems....  1 is drag in the magazine so it does not start to point upward when it comes to the top of the magazine and hits the ramp and cannot slide up it because of the angle it hits it or it may not even come all the way up in the tube at all.  Also if it is to long it can turn your mags into "salt and pepper shakers"......

Thanks for measuring for me!! Gonna work on the mag lips tonight and hope it solves my issue. All my ammo average 1.135-1.40

Share this post


Link to post
Share on other sites
36 minutes ago, Feegee Dean Matlock said:


Wow. That pretty short, but I bet you never have any problems running that. How much powder do you use?

Also with my CZ and my DVC not only was it not throated enough it didn’t like certain bullet profiles. I opened the STI up because I did not want to only be able to shoot certain Bullets. I wanted to have a choice. Most open shooters run a length of 1.160 to 1.170, but in a CZ its a different story. I found it was 1.135 to 1.145 at the most.

 

I’m using 4.1 Grs of Winchester 231 right now. That’s what I had available when I bought the Czechmate so I used that for the range test. Once I get my HS6 powder, I’ll be loading and testing that with 115 Gr JHP from RMR reloading. 

Share this post


Link to post
Share on other sites

I adjusted my mag feed lips. They were way too tight. They were right at .35-.36. Opened up the front to .38 and now the rounds point straight into the chamber and come out smoothly. But now I have new issues. Looks like the chamber is indeed too tight. So now I have a Manson ream tool on the way. Along with czc springs and followers. 

 

Also when I was in the garage manually cycling the slide to wear the parts in, every 20 or so racks the slide would hang where it touches the hammer. I sanded the area down a little with 1200 grit and it seems to cycle smoother,  but still hangs up from time to time. I probably cycled the slide 120+ times tonight 

77CD09A9-DFE5-4E5D-808E-0C21EE810000.jpeg

E0BF4A30-F550-4213-BBA1-4E3FA9F2EDDB.jpeg

FE4BB18F-7C4C-4DC0-9922-48D1D9A2076E.jpeg

Share this post


Link to post
Share on other sites

I hope that is a dummy round ;)

 

I would shorten the OAL, I prefer less than 1.130. 

 

I also run a factory recoil spring. 

Share this post


Link to post
Share on other sites

When you say “cycle the slide” are you letting it go from the rearward position or riding it home?


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...