Jump to content
Brian Enos's Forums... Maku mozo!
TGibe

CMMG Guard tuning (9mm)

Recommended Posts

Called CMMG and my OAL should be good. Said pretty much if it fits in a glock mag then the guard should eat it up. Sent them the pic and they said this issue "may" be similar to one they discovered and are working on.

 

It's really nice to be able to talk with folks that are willing to listen to someone who wants to run a gun in competition and doesn't just give you the "run it stock with factory ammo" line.

 

Cheers,

Allen

Share this post


Link to post
2 hours ago, TGibe said:

 

Thanks Bart. What OAL and bullet are you running?...

I shoot Fiocchi factory 115 FMJ, 1.155".

Share this post


Link to post
2 hours ago, TGibe said:

... they said this issue "may" be similar to one they discovered and are working on...

Would be good to know about this "maybe" issue, as I want to be able to use different kinds of bullets, like HP, etc.

 

I haven't seen this issue reported on any forums yet.

 

I had a friend with the Colt CMMG that was having some problems.  He sent it to them and when he got it back there were no more problems.

Share this post


Link to post
20 minutes ago, BartCarter said:

Would be good to know about this "maybe" issue, as I want to be able to use different kinds of bullets, like HP, etc.

 

I haven't seen this issue reported on any forums yet.

 

I had a friend with the Colt CMMG that was having some problems.  He sent it to them and when he got it back there were no more problems.

 

He didn't go into details and I didn't press.

 

I will post the results. It's been a long journey for me, but I hold out hope for a good resolution.

Share this post


Link to post

I throated my guard barrel to be able to run 147gr JHP at 1.15 in OAL.  They would not pass the plunk test on the stock barrel. 

Share this post


Link to post

I am running a gutted carbine buffer. It seemed to make the rifle cycle faster.  I did not put a timer to it, but it felt like my blowback rifle cycled faster than my guard upper with the stock buffer.  They feel the same now, with exception that the guard is much softer.   My brass is ejecting toward the muzzle at a very shallow angle.  I have not opened up the ejection port, yet.  I am getting a few pieces of brass not making it out of the gun now that the buffer is gutted.  Has anyone made note of the ejection angle on a factory gun?  I am going to attack the guard upper with my Bridgeport sometime this week when I get caught up on other work.

Share this post


Link to post

You running it too light brass going forward means the bolt is striking the empty when coming forward, and it is supposed to be slower than a blow back, put H2 buffer in it

Share this post


Link to post

Try something in the 3 oz range Brian. 

Share this post


Link to post

Quick Update: Complete rifle shipped back to CMMG to see if they can figure out what's going on. Left my hyperfire trigger and ambi safety installed in the off chance that has something to do with it (but I doubt it). Anyway, super nice folks to deal with, but I hope this gets corrected once and for all this time.

 

Fingers crossed...

Share this post


Link to post

Sub'ed to see the outcome of this.  I'm very interested in the 8" barrel/BCG combo.   Are all you guys running the 16" version?

Share this post


Link to post

More data points for guard owners.

 

Suppressed 8" 45 appears to jar top round in magazine forward ONLY when not using 2oz carrier weight (stock 3.7 buffer)

 

Unsurpressed 8" 45 still ejects and cycles quick and soft while using 2oz carrier weight (stock 3.7 buffer)

 

Suppressed 5" 9mm ejects brass into deflector HARD even with 3.5oz carrier weight.

 

Today, CMMG informed me they ship 5" Banshee model with AR10 spring and gutted .9oz buffer.

 

Personally noticed carrier return speed much higher than 45, bolt closing HARD.

 

My next step is swap in the lighter AR15 spring and/or heavier buffer to compare ejection.

Share this post


Link to post
On 2/23/2018 at 10:56 AM, TGibe said:

Quick Update: Complete rifle shipped back to CMMG to see if they can figure out what's going on. Left my hyperfire trigger and ambi safety installed in the off chance that has something to do with it (but I doubt it). Anyway, super nice folks to deal with, but I hope this gets corrected once and for all this time.

 

Fingers crossed...

What ever happened with this?

Share this post


Link to post

I’m still having fail to feed on fully loaded 41 round mags. Tried all weights without any change. Tried different power factor loads, OAL, etc. Have sent it back twice now... once mag is downloaded to around 34-35 rounds runs fine. 

 

I have a friend with a guard guard and now I need to meet up with him and swap mags, etc to see if it’s mags or the gun. 

 

 

Share this post


Link to post
12 hours ago, TGibe said:

I’m still having fail to feed on fully loaded 41 round mags. Tried all weights without any change. Tried different power factor loads, OAL, etc. Have sent it back twice now... once mag is downloaded to around 34-35 rounds runs fine. 

 

I have a friend with a guard guard and now I need to meet up with him and swap mags, etc to see if it’s mags or the gun. 

 

 

 

Seems to me that the gun runs right with factory mags and the 41 round mag does not feed properly.  If this is the case, I would look at what needs to be changed in the 41 round mag to make it feed like the factory mags.

 

Since I shoot for the love of shooting, I use factory mags and reload if needed.  I actually love the reloading part and even starting unloaded.  Makes me a better all-around student-of-the-gun.

Share this post


Link to post
17 minutes ago, BartCarter said:

 

Seems to me that the gun runs right with factory mags and the 41 round mag does not feed properly.  If this is the case, I would look at what needs to be changed in the 41 round mag to make it feed like the factory mags.

 

Since I shoot for the love of shooting, I use factory mags and reload if needed.  I actually love the reloading part and even starting unloaded.  Makes me a better all-around student-of-the-gun.

 

Yup. Really trying to find out why the 41 round mags work 100% (not 99.99999% - I've actually NEVER had a failure) in my $600 PSA gun, but not in the more expensive CMMG.

 

I love competing and can't be competitive if I have to reload during a stage and all other competitors don't have to. 

 

I chose this gun because I didn't want to go the Sig MPX route. Right now, I'm wishing I had. LOL

 

Seriously though, I do appreciate you taking the time to comment. Any frustration you notice in my reply isn't directed at anyone on this forum (especially you), because everyone is super helpful and supportive as I work through this. It's just that I ordered this gun last November and have sent it back twice for two other problems (which have been fixed) and now I'm facing a third problem... Right now it's a paperweight to me because I only plan to shoot it in competition... LOL - definitely a first world problem.

 

 

Share this post


Link to post

Yes, I hear you.  I don't like to give up the time to the big mag carriers, but just accept it.  I have changed my outlook since I stopped road racing.  (I still enjoy winning and I am competitive, but mostly it is how well I feel that I personally do.)

 

I really like the Guard, I hope you get it where you want it. ?

Share this post


Link to post
4 hours ago, TGibe said:

 

Yup. Really trying to find out why the 41 round mags work 100% (not 99.99999% - I've actually NEVER had a failure) in my $600 PSA gun, but not in the more expensive CMMG.

 

I love competing and can't be competitive if I have to reload during a stage and all other competitors don't have to. 

 

I chose this gun because I didn't want to go the Sig MPX route. Right now, I'm wishing I had. LOL

 

Seriously though, I do appreciate you taking the time to comment. Any frustration you notice in my reply isn't directed at anyone on this forum (especially you), because everyone is super helpful and supportive as I work through this. It's just that I ordered this gun last November and have sent it back twice for two other problems (which have been fixed) and now I'm facing a third problem... Right now it's a paperweight to me because I only plan to shoot it in competition... LOL - definitely a first world problem.

 

 

the taylor freelance sight has videos on how to make sure your +10's run well. I had a problem getting them to even load past 30 rounds when I first got them. I had to smooth off the sharp corners on the follower and bevel the end of the mag inside where the mag joins the extender. After that, and some pushing with my mag loader I was able to get them to 41. The factory Freedom Munitions I was running would not feed when the mag was at 41, so I backed it off to 40 and all is good.

 

Can't stress enough to watch the video that is on the TF sight. (this has been discussed a lot in other threads)

Share this post


Link to post
On ‎2‎/‎23‎/‎2018 at 1:56 PM, TGibe said:

Quick Update: Complete rifle shipped back to CMMG to see if they can figure out what's going on. Left my hyperfire trigger and ambi safety installed in the off chance that has something to do with it (but I doubt it). Anyway, super nice folks to deal with, but I hope this gets corrected once and for all this time.

 

Fingers crossed...

So what kind of problems has  CMMG FIXED?

Share this post


Link to post

Any updates? I've got trouble not feeding 33 round Glocks when full, and few failures to eject. CMMG sent me a new extractor which had locking lug shortened.

I'm playing with ejector and extractor tension. I think the extractor looses the rim and the ejector just drives case forward.

Share this post


Link to post

FWIW, I have not had any of these problems with my CMMG Guard.  Does this also happen if your Guard is cleaned and lubed?  I would suggest sending your PCC to CMMG.

 

I am currently using a carbine flat spring and a light hydraulic buffer.

Share this post


Link to post
8 hours ago, cking said:

Any updates? I've got trouble not feeding 33 round Glocks when full, and few failures to eject. CMMG sent me a new extractor which had locking lug shortened.

I'm playing with ejector and extractor tension. I think the extractor looses the rim and the ejector just drives case forward.

After I got it back it still had the same problem.  Sent in a slow mo video to CMMG and they thought the bolt was moving too fast so I installed the heaviest weight from their tuning kit with the same problem. I'm still not able to run fully loaded 40 round mags. Been too busy with a new job to meet a friend at the range to swap mags and parts to see what the real issue is. CMMG is trying to work with me, but my use case (USPSA competitive shooter) probably isn't in their roadmap. The CMMG people I talk to are great and they listen and try to help, but the problem is that I ordered the gun for competition last November and still have yet to be able to use it due to reliability issues.

 

Hopefully I can do some testing with a friend next week, but if I can't get a resolution after that I'm going to buy a Sig MPX as I need something to run that will have less recoil than my blowback gun.

Share this post


Link to post

Her is two things I've done that help, but are no panacea for the problem. Load mags full and let them sit for week to take a set, lots of oil on bolt carrier and into the recoil tube. CMMG support has it problems as you never get to talk with the engineer. But they have been helpful reading off the list of known problems/causes.  

Share this post


Link to post
1 hour ago, cking said:

Her is two things I've done that help, but are no panacea for the problem. Load mags full and let them sit for week to take a set, lots of oil on bolt carrier and into the recoil tube. CMMG support has it problems as you never get to talk with the engineer. But they have been helpful reading off the list of known problems/causes.  

Thx. I'm not messing with my existing mags any more as they work 100% in my blowback gun - I've literally never had a problem with them, not once. So I don't think it is the mags, but I will go through the process of using my buddies guard with my mag and my mags in his guard to see what happens. If my mags run fine in his Guard then I know 100% its the gun...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×