Jump to content
Brian Enos's Forums... Maku mozo!

Recommended Posts

I really love using my new MagnetoSpeed V3 but I have a minor issue that I’d like some help with.  It seems that no matter how much I tighten the strap, the bayonet very slowly migrates forward on my 308 Savage due to the recoil.  After about ten shots, the muzzle is no longer over the metal blast shield area and is over the middle of the loop.  It isn’t coming loose and doesn’t seem to affect the results but I have to keep moving it back and trying to tighten it more.  

Do other users run into this and is there any way to keep it from happening like replacing the strap with another type or maybe adding something to the strap where it comes in contact with the barrel?  It isn’t a huge problem but it’s a little frustrating to keep stopping every 5-10 shots to reposition it.

 

Update-  I sent an email to 6.5 Guys and they were good enough to respond same day.  They made the suggestion that I use the rubber heat shield that came with the V3 and is normally used with a suppressor and to put it between the strap and the top of the barrel.  I haven’t had a chance to try it yet but I’m betting that it will cure the problem.

Edited by tcoz

Share this post


Link to post
Share on other sites

I'm a little late responding. I had the same issue with my magneto speed. I used the rubber heat shield and it seemed to fix the problem. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...