Jump to content
Brian Enos's Forums... Maku mozo!
1eyedfatman

Bolo tuning advice

Recommended Posts

I have 2 Limited Pros, one new generation, one previous generation (curly beaver tail),  The newer generation was beautifully tuned by the person I bought it from with Titan hammer, Bolo, PD springs and 13# hammer spring.  The DA is 6# and SA 3# and everything goes bang...which is fine by me.  And the Bolo is such that when releasing the trigger after the hammer is re-cocked, once the trigger resets, it doesn't  move forward any more and the trigger is right there for the break on the SA.  I want my other Lim Pro like that!

 

This is my 2nd Bolo on this other gun, the first Bolo I had stock trigger, sear and sear housing and I had to file the crap out of the inner curve to get the SA action work...essentially turning it into the same profile as the factory interruptor!  But, I have recently installed a Titan hammer, Xtreme sear and sear housing on this gun and thus ordered a new Bolo.

 

For 2 days, I have been sanding away at that inner Bolo curve with 800 grit sandpaper trying to get the SA to break.  Going slow and steady so as not to take off any more then necessary and introduce trigger play.  The number of times I've sanded, installed and tested is countless.  I have now pulled out the dremel on this bitch.  I am still being careful not to over do it and testing often, but my patience is wearing thin!

 

Is there a more targeted area to file the inner curve of the Bolo?  I've been trying to do an even filing according to the picture on the PD site (the #1 area).  But maybe focus on the center part of the curve where the mass is or maybe the in towards the downward pointing toe?

Share this post


Link to post
Share on other sites
35 minutes ago, 1eyedfatman said:

DA looks to work.  No overtravel screw in this stock Limited Pro trigger.

can you post a  pic of what area your hitting on the BOLO......

Share this post


Link to post
Share on other sites
27 minutes ago, SoCalShooter69 said:

So DA works, SA does not?

 

What's SA pre travel like? Is it still not re-setting or breaking in SA with no pretravel?

 

DA works, SA does not.  And per instructions, SA is the first thing to adjust on the Bolo.  I cannot get the trigger to reset on SA, i guess it doesn't move forward enough to "click" into reset.  No pre travel at this point because the trigger doesn't even reset.

Share this post


Link to post
Share on other sites
5 minutes ago, PatriotDefense said:

can you post a  pic of what area your hitting on the BOLO......

 

If by "what area your hitting on the Bolo", you mean where I am filing, its the exact curve on the PD website instructions picture for #1 and I'm following that natural flat curve on the filing/sanding.  If you mean something else, can you clarify?

Share this post


Link to post
Share on other sites
44 minutes ago, 1eyedfatman said:

 

If by "what area your hitting on the Bolo", you mean where I am filing, its the exact curve on the PD website instructions picture for #1 and I'm following that natural flat curve on the filing/sanding.  If you mean something else, can you clarify?

Sounds like you have an unlucky Lim-Pro that's going to require a bit of material to be removed. Sand paper more than likely will make you want to throw the thing away before you actually get it fitted. Remember its a hardened piece of metal so going to the dremel will shave hours of time. Just go slow and keep the cut straight.... your on the right track

Share this post


Link to post
Share on other sites
1 hour ago, PatriotDefense said:

Sounds like you have an unlucky Lim-Pro that's going to require a bit of material to be removed. Sand paper more than likely will make you want to throw the thing away before you actually get it fitted. Remember its a hardened piece of metal so going to the dremel will shave hours of time. Just go slow and keep the cut straight.... your on the right track

 

Just to echo what Joe is saying - I've had small frames where bolos dropped right in and large frames that needed an unfathomable amount of material to function. That's just the roll of the dice you take when dealing with the very incosistant QC from Tanfo. If you're being explicitly correct in your description, and not leaving anything out, or an error on your end - keep removing material.

Share this post


Link to post
Share on other sites

Thanks Joe and everyone.  I got the dremel after it again tonight.  Kept saying "just one more pass" and I eventually got it!  The single action now resets and has virtually no pre travel!  Much better then the standard interruptor.  Now I have to fit the single sided safety.

 

My SA dropped from 3.5# to 3#.  My DA is still 6.5#-6.75#.  I'd like that down to 6#.  Any ideas?

- I noticed the comments about adjusting the Bolo for a longer DA pull and that may liten the DA trigger...but, risky given the work I've put into my Bolo already.

- I could put a liter trigger plunger spring in like the CGW spring talked about on this forum or clip a coil off my current liten spring, but the SA reset doesn't seem real positive currently (there is no audible click on the reset but it does reset).

- Take it apart and go through another round of polishing and oiling.

Share this post


Link to post
Share on other sites

Fire 500 rounds.

Take it apart and polish it fully. Concentrate on all areas showing rubs.

Share this post


Link to post
Share on other sites
4 minutes ago, johnbu said:

Fire 500 rounds.

Take it apart and polish it fully. Concentrate on all areas showing rubs.

 

I literally was just about to type to OP "Just go shoot the gun."

 

You likely need a good (or better polish job). Follow what Johnbu recommended. I will say, don't change out the plunger spring. Also, the nature of the bolo is an almost inaudible reset. 

Share this post


Link to post
Share on other sites

Almost every gun will hit 6 pounds or so with a 13 pound PD and Titan/Bolo combination once its polished internally well enough.

 

Spend much of your time sanding machine marks out of, and then polishing, the plunger assembly. No zipper feel allowed to remain when squeezed.

 

The pins and their holes need an equally intense amount of attention if you hope to hit fiveish pounds someday.

 

That said? Go shoot the guns bunch. After playing with springs and such like mad while shooting lots of matches, there's no difference between a 5.5 and a 7lb DA when there's a timer ticking. Practice is a better use of your energy than dremeling.

Share this post


Link to post
Share on other sites
11 hours ago, 1eyedfatman said:

Thanks Joe and everyone.  I got the dremel after it again tonight.  Kept saying "just one more pass" and I eventually got it!  The single action now resets and has virtually no pre travel!  Much better then the standard interruptor.  Now I have to fit the single sided safety.

 

My SA dropped from 3.5# to 3#.  My DA is still 6.5#-6.75#.  I'd like that down to 6#.  Any ideas?

- I noticed the comments about adjusting the Bolo for a longer DA pull and that may liten the DA trigger...but, risky given the work I've put into my Bolo already.

- I could put a liter trigger plunger spring in like the CGW spring talked about on this forum or clip a coil off my current liten spring, but the SA reset doesn't seem real positive currently (there is no audible click on the reset but it does reset).

- Take it apart and go through another round of polishing and oiling.

Polishing all the pins, and pin holes will probably get you to the 6lb range your looking for. 

Share this post


Link to post
Share on other sites
3 hours ago, PatriotDefense said:

Polishing all the pins, and pin holes will probably get you to the 6lb range your looking for. 

 

I always get a warm fuzzy feeling when Joe posts. :)  Thanks Joe!

Share this post


Link to post
Share on other sites
36 minutes ago, 1eyedfatman said:

 

I always get a warm fuzzy feeling when Joe posts. :)  Thanks Joe!

This was actually JoAnna....... but ill be sure to tell Joe that you get a warm and fuzzy when he post :P

Share this post


Link to post
Share on other sites
28 minutes ago, PatriotDefense said:

This was actually JoAnna....... but ill be sure to tell Joe that you get a warm and fuzzy when he post :P

 

Even warmer and fuzzier when the boss's boss posts !  lol

Share this post


Link to post
Share on other sites

reviving this old thread.
Thank Joanna and Joe for their awesome products, they were unobtainable here in Canada but I recently was able to get them through my TANFO rep Freedom Ventures.

 

I am happy to report a 5lbs 4 ounces trigger with a chrome tanfo with YELLOW PD mainspring and their reduced power springs. These gun has a trigger job done by myself, however I spent 1/3 of the time polishing it as I did my previous one and this is one is 10 times better. The luck of the draw, some frames are harder than others...

 

I took it to the range yesterday and I popped S&B primers no problem! with a 5lbd trigger??????!!!!! unreal.

 

Thank you guys! :) @Garcia_IPSC on IG, gonna make a post about this.

Share this post


Link to post
Share on other sites
Posted (edited)

Raising an old topic. Installing the BOLO has turned out to be quite a PITA. 

 

I now have following parts in my small frame stock 2 

 

- xtreme titan hammer 

- xtreme sear

- extreme firing pin

- pd springs 

- 15,5 lbs hammer spring 

- xtreme trigger bar 

- xtreme trigger bar guide

 

I took out the 0.020" from the arc. The reset didn't always work. DA would not engage at all. I ended up taking 0.040" out of the arc. SA works now. Obv there is now quite a bit of pretravel in SA. DA now engages but is short stroking. The throw is maybe half of the needed. The bolo is now probably ruined but what do need to do to make it work. Shorten the part that rides the frame?  Am I using too heavy spring. Will that have any effect?

 

I'm guessing something in my parts or frame is just horribly out of spec. But what are the right methods to fix the DA not engaging problem. Everything works with the original disconnector albeit the DA throw is still shortish. But still probably double compared to BOLO.

 

I feel kinda dumb since it all seems so simple from the instructions.

Edited by Tirppa

Share this post


Link to post
Share on other sites

I have a new small frame Lim Pro I've been trying to bolo. I'm on my 2nd one (I wish PD had a trade in program while you figure it out..) 

So I think to get the DA to work on the SF you need to remove material from the inside  front of the curve to increase the DA throw. I tried removing material from the 'point' 

as someone suggested but it didn't work. I introduced a little SA pre travel with the 2nd one, I may try a 3rd at some point to see if I can get it 100% there. 

_______________

|   ____________|

|  /   <------- remove material here 

|/

 

Bad asciii art, I can take some pics if need be but I don't want to take that thing apart for awhile. 

 

 

Share this post


Link to post
Share on other sites

ASCII art is perfect. I'm gonna go shoot some A hits slowly at the nationals this weekend but I'm gonna see what happens when I remove material from there. It will probably add a lot of pretravel and gonna be pretty close to the stock disconnector. 

Share this post


Link to post
Share on other sites
On 7/24/2019 at 2:04 PM, Tirppa said:

Installing the BOLO has turned out to be quite a PITA. 

Call PD

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...