Jump to content
Brian Enos's Forums... Maku mozo!
smfort

Apex Flat-Faced Forward Set Sear & Trigger Kit

Recommended Posts

Hello Everyone!  First off I would like to say that I am new to the forums and I was directed to post this question here!  

 

So here it is:  I have a S&W M&P 45acp  that I installed an Apex Flat-Faced Forward Set Sear & Trigger Kit into and I have had issues with double firing.  The gun is brand new and nothing else has been done to it and I had no problems up until this point.  I think it might be the sear spring but not sure (it was recommended that it might be the sear spring this morning, I have not tried it yet).  Anyway, when I initially installed the kit I put the weaker spring in and I really thought the trigger pull was a bit light, but nice none the less.  Anyway, I had several "doubles" and I thought that it might have been the combination of the light trigger, the recoil and the fact that I might have been "riding the trigger" a little bit.  So I install the heavier trigger return spring (the green spring) and test fired the gun and it did great, as a matter of a fact I ran it 2 complete matches with no issues..then this past Sunday at a match doubled on  me 4 times in the first stage.  Several fixes have been suggested the one that I am planning to try next is to replace the kit provided sear spring with the factory sear spring and if that does not work then I am planning to reinstall all of the factory parts.  

 

Any suggestions are greatly appreciated and I would like to thank you all in advance.  Also, it is very possible that I have something installed incorrectly this is my first trigger job so again any suggestions, comments, recommendations, etc...are greatly appreciated and thank you all again in advance.

 

-smf 

Edited by smfort
add text

Share this post


Link to post
Share on other sites

This also happened to a friend of mine and she took it to a local gunsmith who took care of it. Unfortunately I don't know what was done to solve the problem. BTW, he had also  installed the Apex parts. 

Share this post


Link to post
Share on other sites

dapribek, 

 

Thanks for the reply.  I talked to a local gunsmith earlier today and he said to try the factory sear spring with the other Apex parts and if that does not work to call him back.  Thanks again!

Share this post


Link to post
Share on other sites

Yes I have been in contact with them and they are and have been very helpful.  They have requested that I send them pictures of the install which I am going to do next.  

 

Thanks,

-smf

Share this post


Link to post
Share on other sites

I do not think I did but I will recheck it.  I think I might have gotten the issue fixed.  I found a very small amount of what appeared to be trash (I mean "very small" extremely hard to see) between the Striker Spring and the Striker Spring Guide, so I took it apart, cleaned it really well and put it back together...test fired it and did not have an issue.  Of course I had test fired it before this and not had any issues also!  I guess will just watch it to see what happens.  

 

Thanks for the reply, I will check to make sure I have the correct seat spring installed again to be sure.  

 

Thanks,

Scott

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...