Jump to content
Brian Enos's Forums... Maku mozo!
Sign in to follow this  
DPA

Jm pro issue with slugs

Recommended Posts

*After searching numerous forums and web-sites and coming up empty I decided to join this forum. (Converted troller) My apologies if this issue is listed elsewhere or needs to be posted elsewhere.*

I am having a problem with my new JM pro. During a three gun match I shot 73 rounds of shotgun shells. 60 of these shells were #7.5 birdshot, 10 were #9 bs and 3 were slugs (winchester, 2 3/4, 1oz 1600fps). All of the rounds fired and cycled correctly with the exception of the 3 slugs. When firing the slugs, the shotgun locked up with the bolt in the open position. Pushing the bolt release button cycled the bolt forward and then I had to manualy load the next round. After the third slug I manually chambered in the #9 birdshot and finished the stage with no problems. Before I shot the shotgun I thouroughly cleaned and prepped the gun as prescribed by JM's and other youtube videos. If anyone has a solution I surely would appreciate it. Thanks.

-DPA

Share this post


Link to post
Share on other sites

Try a different brand of shells and see if the problem persists. When I had my JM Pro, it loved to shoot the Fiocchi low recoil 1oz 1150fps shells, was all I ever used.. very soft.

Share this post


Link to post
Share on other sites

I shoot Federal trubal low recoil. I have shot some of the 1600 fps stuff with no other issue than excessive recoil. Not an answer, just experiences.

Share this post


Link to post
Share on other sites

I put the OR3Gun stuff in my shotgun and shoot Federal Ammo with zero malfunctions.

I find the OP's problem interesting because you usually hear that a gun will run heavy loads but not light stuff. Hopefully one of those knowledgeable guys will chime in.

Share this post


Link to post
Share on other sites

How light is the magazine tube spring you are running? Have you modified the original for easier loading and less tension?

In some cases, springs that are bit too light will not quite get a shell to stay solidly behind the shell stop in order for the rest of the gun to get the memo that you didn't just shoot it empty instead. This is especially the case when the inertia of a full power slug is driving the gun (with the remaining shells in the tube) back against the spring that is supposed to be feeding the shells down the magazine tube. The object at rest (the rounds in your tube) are wanting to stay at rest and can't be overcome by the weak magazine tube spring when the rest of the gun moves sharply under recoil. The weak spring doesn't efficiently keep the shells in the magazine tube shoved up to the shell stop under heavy recoil, which causes the gun to lock open as empty instead of feeding another round.

I hope that made sense. It has been a long day and I probably took too many words to suggest trying a heavier magazine tube spring.

Share this post


Link to post
Share on other sites

Logiztix: Yeah, I'm actually understanding what you mean. I'm hoping it is just a spring issue. The spring I'm using is stock from factory. I ordered some Fed and Fiocchi LR slugs. I'm hoping they will fix the problem. I kinda like Using this spring because it's shooting lite rounds with no problems. My thanks to all of ya. I will let you know how next match or trip to the range goes.

Share this post


Link to post
Share on other sites

Follow up: I shot in another match and gun malfunctioned again. This time with #7 birdshot. I called Mossberg CS and they want it back to inspect and replace bolt. Wishing I had the cash for Benelli.

Share this post


Link to post
Share on other sites

I had a problem with my 930 locking up when firing any heavy load. Took it back on warranty they replaced something in the lifter assembly but, didn't tell me what. No problems since then. On the rare occasion I need slugs I've been running Remington Reduced Recoil (easy to find locally).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...