Jump to content
Brian Enos's Forums... Maku mozo!
rhart123

CZ P01 Dead Trigger in SA - Need Help Please

Recommended Posts

I recently installed a CGW competition hammer on my CZ P01 and everything worked fine for about 300 rounds. On my fourth outing with it the trigger got hard to pull a couple of times and then went dead. I can decock it and shoot one shot in DA, but the trigger is dead for the SA shot. I took it home and wiggled the trigger until it started working again and lubed it up just in case. This morning I took it back to the range and after about 8 shots it got hard to pull in SA and then went dead again. I brought it home and wiggled the trigger again and now it works in SA, but there is a delay before the hammer falls. Any suggestions as to what I may have done wrong in the install? Thanks for any help.

Share this post


Link to post
Share on other sites

Please disregard, I figured it out (he said with a sheepish look on his deep red face). I recently installed an 85C trigger on this P01 and the overtravel screw had backed out and wasn't letting the trigger pull back far enough to shoot. I didn't need it, but left it in, but now I've removed it (the screw).

I apologize for wasting the time of anyone who looks at this post - but maybe you will get a laugh at my expense!

Share this post


Link to post
Share on other sites

Sometime it takes a step from the problem to find the solution. I'm sure no one thinks u wasted anyone's time. Truthfully I'm here to waste some time most of the time.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...