Jump to content
Brian Enos's Forums... Maku mozo!

Newbie question about wear issue on 2011 frame


EdRooney

Recommended Posts

Two years lurking and now ready for my first post. I bought this 2011 edge almost two years ago and had it set up for major loads then wanted to run minor. The gunsmith I bought it from said to just change the spring and all would be good. I had some problems with the last round in the magazine not feeding properly, so I lowered the spring again on his recommendation. It now runs like a champ, but I saw this area last night when cleaning and it got me worried. I currently shoot 40 S&W 165g at about 850ft/sec and a ISMI 10lb spring. The original guide rod was removed and replaced and he put in a shock buff as well. Any help would be appreciated. The area in question is circled in red and it looks like it has been smashed compared to the right side

post-47164-0-31525600-1431964380_thumb.j

post-47164-0-08322200-1431964405_thumb.j

post-47164-0-75139000-1431964422_thumb.j

Link to comment
Share on other sites

The area you're circling shouldn't have any metal on metal impact from use. It's the window where the slide stop "pawl" is inserted and travels up and down to engage or disengage the slide. Take a look at your slide stop and see if there is any odd wear on it. If the slide stop is not original, is poorly fitted, or the wrong caliber it might cause issues in this area either during cycling or when inserting or removing it.

Without going into all the possible causes, I'd just dress it down with a Swiss file, shoot it more, and keep an eye on the area. It's probably just an inadvertent "idiot" mark. No offense. We all have these happen from time to time when servicing our pistols.

Hope that helps,

Cheers623

DVC

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...