Jump to content
Brian Enos's Forums... Maku mozo!

Apex Enhanced trigger went to mush and heavy?


ihocky2

Recommended Posts

I installed an Apex Enhanced Action Kit in my 9L a couple of weeks ago and had a great, light, crisp trigger. Shot it about 2 weeks ago and 50 rounds of no problems. I did a few light dry fire sessions since then and everything was good. Today I went to a match and all of a sudden the trigger feels mushy and is hard to get the break. It is still light most of the way and then it seems like it gets to the point that it should break and it doesn't. I have to keep pulling hard to get the last little bit of the sear to disengage from the striker.

The only things I replaced were the striker block, the sear, and the springs. It is still the factory trigger and trigger bar. It seems like the sear just is not moving enough to clear the striker. Playing around on the bench I found that if I rack the slide just a few thousanths of an inch the striker drops like it is supposed to, no mush. I took the slide off and on a few times trying to see what is going on and suddenly the trigger break was back to where is should be. I got excited too quickly because after about 5 dry fires it went back to the same problem of being mushy and not wanted to release from the sear.

First, does anyone have experience with this and how to fix it. Second, what happened that sitting in the safe it suddenly started failing.

Link to comment
Share on other sites

It could be your striker block is getting "hung up" somehow in the bore, If it jams, the trigger bar can bend and the trigger will feel mushy, and be hard to push until the block moves. I'd suggest taking the striker block out and checking it (and the bore) for debris.

Link to comment
Share on other sites

Thanks for the help guys. I adjusted the loop open and it is working correctly again. I was rather suprised, the gap was at .019" to start with and I had to open up to .026". The striker block seems to be disengaging just fine, but that just seems to be a pretty large gap.

Does anyone have a guess as to what could have caused it to close up suddenly? The striker block was moving freely, so there is no debris in it. I am just shocked that out of nowhere it stopped working.

Link to comment
Share on other sites

Hard to diagnose, but you were probably on the edge of reliable functon at the original loop setting, loop not set correctly. Make sure you have a bit of overtravel. A good test of proper loop setting, imho, is to attempt to dry fire while pushing down on back of slide, compressing the slide to frame. There is some clearance between slide and frame, and if pull feels good, then all is well as loaded mag pushes slide away from frame during live fire,.which produces more clearance. If pull is rough or striker does not release, then open loop some more.

Link to comment
Share on other sites

Inspect the loop carefully. Mine broke the other day, likely because of fatigue after repeated flexing - photos below. The fact that it permanently deformed suggests it could be close to failing. If I were you, I would replace the trigger bar before your next major match.

MampP%20Broken%20Trigger%20Bar%201_zpsbd

MampP%20Broken%20Trigger%20Bar%202_zps13

MampP%20Broken%20Trigger%20Bar%203_zpsio

Link to comment
Share on other sites

  • 3 weeks later...

I followed the instructions I found on adjusting the trigger bar loop and it fixed the problem perfectly. I ran about 150 rounds through trying to sort out an ammo issue and then about another 100 in practice. Today at the first local match I shot since the fix it started acting up again, right on a classifier. The trigger was not fully returning to reset every time and I had the same thing where I would pull the trigger and get nothing. A quick slight rack of the slide and it was fine. I went and opened the loop a hair and ran the next 150 rounds without fail.

It seems like there is a problem with the loop and it is getting ready to fail. Does anyone know where I may still be able to find a trigger bar? Everywhere I have checked is sold out due to S&W's dumb parts policy lately. Has anyone come out with an aftermarket bar or anywhere I can get one that I do not have to return this gun to S&W?

Link to comment
Share on other sites

I followed the instructions I found on adjusting the trigger bar loop and it fixed the problem perfectly. I ran about 150 rounds through trying to sort out an ammo issue and then about another 100 in practice. Today at the first local match I shot since the fix it started acting up again, right on a classifier. The trigger was not fully returning to reset every time and I had the same thing where I would pull the trigger and get nothing. A quick slight rack of the slide and it was fine. I went and opened the loop a hair and ran the next 150 rounds without fail.

It seems like there is a problem with the loop and it is getting ready to fail. Does anyone know where I may still be able to find a trigger bar? Everywhere I have checked is sold out due to S&W's dumb parts policy lately. Has anyone come out with an aftermarket bar or anywhere I can get one that I do not have to return this gun to S&W?

http://www.gandrtactical.com/cgi-bin/commerce.cgi?preadd=action&key=39305

Link to comment
Share on other sites

Thanks Bkreutz but I checked them already. They do not show it out of stock, but when you go to add it to the cart they tell you that it is not available.

Stealthy, did they give you any kind of hard time about replacing just the part by sending in the bad one? It almost sounds like once I get the warranty return approved I am going to have to actually break the trigger bar. Right now it is failing, but looks normal in appearance.

Thanks again everyone.

Link to comment
Share on other sites

Thanks Bkreutz but I checked them already. They do not show it out of stock, but when you go to add it to the cart they tell you that it is not available.

Stealthy, did they give you any kind of hard time about replacing just the part by sending in the bad one? It almost sounds like once I get the warranty return approved I am going to have to actually break the trigger bar. Right now it is failing, but looks normal in appearance.

Thanks again everyone.

Roll the dice - mine was broken and they replaced it without issue, as they have in the past with several other broken parts. I had previously sent in a Gen 1 sear block for a Gen 2 replacement and they sent it back asking for the whole pistol to be sent (which of course I did not do). Worst case they send the mushy trigger bar back to you.

Oh, and I NEVER ask for an advanced RMA number... if you call them they will definitely ask for the pistol to be sent to them. I just mail them the part with a polite letter explaining how I am a loyal customer and asking that the broken part be replaced. Chances are it will be easier and cheaper to replace the part than ask for the pistol to be sent in.

You might also want to back order one at Brownells or Midway too... they are cheap enough and always worth having a spare.

Link to comment
Share on other sites

Problem with Brownell's is they only have the S trigger bar, not the latest H version. Not sure of the differences between the 2, but I guess an S is better than non. I have an S in my 5" and H in the newer Compact. Pull is a little better with the H, reset a little shorter as well.

Noticed trigger reset is smoother following polishing sides of loop, as the sear rubs against it. Just watch the operation with slide off. This might be the issue the OP is having. Also, a weaker trigger return spring can lead to same issue, weak/slow reset. Try it with OEM trigger return spring. Should still get a 4 lb trigger pull and hopefully reliable reset.

Link to comment
Share on other sites

Thanks Bkreutz but I checked them already. They do not show it out of stock, but when you go to add it to the cart they tell you that it is not available.

Stealthy, did they give you any kind of hard time about replacing just the part by sending in the bad one? It almost sounds like once I get the warranty return approved I am going to have to actually break the trigger bar. Right now it is failing, but looks normal in appearance.

Thanks again everyone.

Try calling them, I've had that problem with ordering online and when I called them, they had the part. (worth a call)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...