Jump to content
Brian Enos's Forums... Maku mozo!

CZ P-09 Double action issue


blacklab2011

Recommended Posts

I have a CZ p-09 I bought from classifieds here (approx 500 rounds at time of purchase), previous owner installed CGW Hammer and trigger components. Should clarify I have no issues with seller, gun has functioned great up until now. I have approx 2k down the pipe since purchase.

Issue happened at last match, trigger is dead when pulling trigger with hammer down in double action mode. Trigger moves but hammer does not, however I am able to run the gun in single action. Actually finished the match by racking slide or cocking hammer off the draw. Not an optimal way to shoot a stage but at least I was able to finish the match.

Wondering if anyone has had a similar experience or has an idea of what the issue might be?

Link to comment
Share on other sites

Look at part 49 on the P-07 diagram. The trigger bar spring. It more than likely slipped out of the grove under the trigger bar. All you have to do is put it back, unless it is broke.

Jason

Link to comment
Share on other sites

Thanks for the responses. DA still not working, I did check the trigger bar spring and everything looked fine, still intact and in its place under trigger bar. When cocking hammer trigger would normally move backwards as well to single action position. Now when cocking hammer, trigger stays in forward most position. SA works but makes for a really long SA pull.

Link to comment
Share on other sites

Ok, that sounds like the disconnector that is pinned to the hammer is broken. Check to see if there is a piece of metal that moves under the sear cage from the front to rear as you pull back the hammer. If it moves normally with no up and down movement (vertical) there is another problem. I am sure Stuart will be able to explain it a little better and the fix.

Jason

Link to comment
Share on other sites

Found this issue tonight. Thanks to Joe L's YouTube videos I was able to disassemble the lower tonight. Kept thinking I was missing a piece...turns out the piece on the side of the hammer (I know real technical ) that holds the disconnector was broken off and the whole disconnector was missing.

Hard to believe gun would still function in SA with the disconnector missing.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...