Jump to content
Brian Enos's Forums... Maku mozo!

Benelli M2 problem


jmfs21

Recommended Posts

I have been shooting my Benelli M2 for 6+ years now and havent had much of a problem up until late. Starting the beginning of last year and progressively getting worse, the last shell or 2 gets stuck on the lifter. I have had every spring in the gun changed out along with multiple new Mag springs. It has a 12 round tube on it and the spring sticks out about 14 inches. i dont cut the mag spring at all. Any help would be greatly appreciated. It feels like it gets actually "stuck: to the lifter.

Thanks,

John Spreitzer

post-33153-0-95534400-1429397709_thumb.jpost-33153-0-39173600-1429397717_thumb.j

Link to comment
Share on other sites

Clean the mag tube and make sure you are running the low drag follower. I had the same issues. I now make sure that the inside of the mag tube is pristine. Bore brush chucked in a hand drill. Smooth and clean and I run a low drag follower. I also do not cut the spring.

Link to comment
Share on other sites

400 grit the few minor bumps on the inside of the reciever then followed up with 1000 grit and 2000 grit. Cleaned the snot out of the mag tube (xrail 1 piece), brand new mag spring. Polished the top of the lifter and cleaned entire firing mechanism. Entire gun has all new springs. Took it our yesterday and it happened yet again costing me the stage.Any other ideas?

Link to comment
Share on other sites

You indicated all new springs, to include the recoil spring in the butt stock? Some waterfowlers had trouble with water intrusion rusting that spring and causing issues. Something to look at if you haven't already.

Link to comment
Share on other sites

Winchester AAs only? If you "stab" hard when you Twin or Quad load, you can mash out the crimp and make it out of round inducing that exact failure. First in (the stab shell) is the last out.

I can produce that malfunction on demand with a AA, but not with any other shell.

Link to comment
Share on other sites

John,

What shape is the carrier latch in? Has it been modified any? Over time, folks who practice their loading will squeeze on that latch to unload the tube, and eventually it will bend out and not catch shells well. Then they bend it back some, and can occasionally be a little too much. Not sure if you've messed with it much, but its something to look at, also.

Also, you said all springs were new.. Im assuming you put a new carrier spring in for the breech bolt latch?

Link to comment
Share on other sites

  • 1 month later...

Well Brandin over at Xrail sent me a new +power mag tube spring that they use for their 12 round tube and so far so good. I have put around 300 rds through her with no problems yet. I will keep everyone updated.

Link to comment
Share on other sites

  • 3 weeks later...

I had a similar issue with my 1991 H&K M1 super 90. I looked at the back side of the hammer and noticed is was showing some wear. I looked at the end of the carrier and it looked the same way where it resets the hammer. I took some 400 wet/dry and polished both the back of the hammer and the end of the carrier. Then I buffed everything to a mirror finish with semichrome. I also polished the lifter actuator and the area on the backside of the carrier where it actuates the lifter for the next shell. After polishing/buffing, it now runs fine with a 10 round Xrail.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...