Jump to content
Brian Enos's Forums... Maku mozo!
Sign in to follow this  
chuckstur

Dented 40s in 2011

Recommended Posts

My Eagle dents 2% of the rounds during feeding to the extent that they lock the gun up after they enter the chamber. The slide stops about 1/8" out of battery. OAL 1.167" to 1.120" Any help here?

post-46041-0-35015600-1415151758_thumb.j

Share this post


Link to post
Share on other sites

If you're talking about the dent around the middle of the case, it looks like those rounds got stuck at the top of the chamber and dented on the top of the feed ramp. Changing bullet profile or OAL of rounds can fix.

Share this post


Link to post
Share on other sites

Take a real close look at the extractor. Look for burs and look at breach face. Be sure there is no crud in the extractor channel.

If the round cannot slide up under the extractor smoothly during feeding it will do exactly what you are seeing.

Share this post


Link to post
Share on other sites

That's what's doing it. I quit using mine b/c of it.

The Uplula can certainly dent the casings, but those dents come from really smashing rounds (usually w/ an uplula) into an STI mag tube. The "ridges" inside the tube cause the dents.

Share this post


Link to post
Share on other sites

My dents went away when I quit using the uplula, guess I can't cram them in as hard with my thumbs. I run SV mags now but still haven't gone back to the uplula. No biggie.

Edited by CDPMatt

Share this post


Link to post
Share on other sites

Yes, I used the Uplula. Tell me more

Chuck, have you checked and cleaned the extractor and looked at the breech face? What lube are you running?

Here is the deal. I am not claiming to be an expert. I have been shooting competitions at least three weekends a month with this gun, plus practice. It started to do what you describe and picture a little while ago. Normally a light "battery assist" with the heel of my weak hand and keep going. Since cleaning and lubing the extractor mechanism I have run four matches and practice sessions without a single issue. No changes to ANY OTHER variable. Same ammo, magazines, loader and everything.

Oh, just to add to the conversation. I used an UpLULA before, during and after this issue. Any mark from the loader would be on the top of the round. I will bet your dent is on the BOTTOM of the round as it gets hung up on the breech face with the case bottom low and the bullet high (against the top of the chamber) and the dent is from the top of the feed ramp. It is easy to take some gun scrubber to the extractor channel and work the pawl a little with a piece of brass. Do it a couple times and put a drop or two of oil down it and try it out. It is a simple check and will save a lot of frustrations if that is all it is.

Share this post


Link to post
Share on other sites

I will look into the Lupula effect for sure. I chamferred and polished the extractor hook and shot a match without problems but my son had a new failure. Look at his post on Eagle feeding.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...