Jump to content
Brian Enos's Forums... Maku mozo!

Recommended Posts

So I got the SP-01 Tactical apart, polished, reassembled and put back together, but the hammer won't hit the firing pin. It stops about 1/16"-1/8" away. New parts are CGW firing pin, hammer Springs, trigger return spring and disconnected. Hammer is CZC. I'm using my P-01 as a model, and things look pretty similar. I don't have the decocker levers back in. Trigger works in SA and DA.

Call David at CGW. He will get you fixed up.

Share this post


Link to post
Share on other sites

What does the hammer do when it stops? In DA?

Share this post


Link to post
Share on other sites

I had a shadow do that after changing out the disco. I ended up having to mod one of the disco angles and now everything works great. David will send you an email with the instructions if you give him a call.

Edited by Leadpilot

Share this post


Link to post
Share on other sites

I had a shadow do that after changing out the disco. I ended up having to mod one of the disco angles and now everything works great. David will send you an email with the instructions if you give him a call.

I'll call him later today. Would reinstalling the stock disco make the problem go away?

Share this post


Link to post
Share on other sites

Hi Atlas - Great post, btw. So i got a question that maybe you know the answer, I ordered a bunch of parts from CGW for my P-01 (yes, the decocker was a PITA) including the CGW hybrid disco (since I also bought the Reach Reduction Kit) and the Short Reset System. I took the gun apart, put all the new parts in and I still have a reset of like 6mm. That's how much my Xds reset is. I been shooting it like that for a while but it is really starting to bug me, and I am about the dissassemble it again to see if there is anything obvious. Functions great, but the reset is really bugginh me, especially when I read about others putting in the SRS and getting a 2 to 3mm reset. Anything obvious come to mind that I should be looking for? I also plan on polishing things up this time, as last time I had the gun apart I didn't do squat.

Share this post


Link to post
Share on other sites

Found my problem. Encouraged by David I tore back into the decocker. He thought it might have been a poorly installed decocker spring, but I had it hooked on correctly. Switched out to the original disco but the hammer still didn't get forward enough. Finally switched out the CZ Custom comp hammer for stock, and I'll be danged, that was it. Unfortunately I smashed my last L-spring so I'll need to restock.

Edited by Rucker61

Share this post


Link to post
Share on other sites

Found my problem. Encouraged by David I tore back into the decocker. He thought it might have been a poorly installed decocker spring, but I had it hooked on correctly. Switched out to the original disco but the hammer still didn't get forward enough. Finally switched out the CZ Custom comp hammer for stock, and I'll be danged, that was it. Unfortunately I smashed my last L-spring so I'll need to restock.

What was the problem with the hammer? Did you get the correct one?

This is the one you should be getting since you have a decocker model:

http://czcustom.com/czcomphammerdecockeronly.aspx

Share this post


Link to post
Share on other sites

Found my problem. Encouraged by David I tore back into the decocker. He thought it might have been a poorly installed decocker spring, but I had it hooked on correctly. Switched out to the original disco but the hammer still didn't get forward enough. Finally switched out the CZ Custom comp hammer for stock, and I'll be danged, that was it. Unfortunately I smashed my last L-spring so I'll need to restock.

What was the problem with the hammer? Did you get the correct one?

This is the one you should be getting since you have a decocker model:

http://czcustom.com/czcomphammerdecockeronly.aspx

That's the one I ordered. I received this one:

20150519_204422_zpsdngluvuv.jpg

Share this post


Link to post
Share on other sites

That looks like the hammer for a frame safety model to me.

Me, too. Symmetrical as opposed to the asymmetry of the decocker model. Caused quite a bit of frustration in trying to get it to work.

Share this post


Link to post
Share on other sites

Wrong hammer. Send it back, get you the right one . Send me a pm.

Share this post


Link to post
Share on other sites

Ok so I have a question. I have a shadow and just switched to mecgar mags and now I'm having an issue dropping mags with rounds in them. When I try to do a reload with ammo still in the mag it's hanging up. I have noticed when I grab the mag and pull it out the next round Is pushed forward which is what's causing the mag to hang uP. Does anyone know of a fix for this? I don't want to have to pull the mag out when trying to reload.

Share this post


Link to post
Share on other sites

Ok so I have a question. I have a shadow and just switched to mecgar mags and now I'm having an issue dropping mags with rounds in them. When I try to do a reload with ammo still in the mag it's hanging up. I have noticed when I grab the mag and pull it out the next round Is pushed forward which is what's causing the mag to hang uP. Does anyone know of a fix for this? I don't want to have to pull the mag out when trying to reload.

Share this post


Link to post
Share on other sites

Ok so I have a question. I have a shadow and just switched to mecgar mags and now I'm having an issue dropping mags with rounds in them. When I try to do a reload with ammo still in the mag it's hanging up. I have noticed when I grab the mag and pull it out the next round Is pushed forward which is what's causing the mag to hang uP. Does anyone know of a fix for this? I don't want to have to pull the mag out when trying to reload.

The square edge at the bottom of the breech face on the slide can drag the next round forward, if you file this edge, it should take care of your issue:

IMG_20140218_210953_402-1_zps05b6f86b.jp

Share this post


Link to post
Share on other sites

Also polish the center rail. It's what is dragging on the round.

Share this post


Link to post
Share on other sites

I had polished the center rail originally but never touched up the breech face

Share this post


Link to post
Share on other sites

Thanks for the great informative thread.

Convinced my GF to buy a 75B. She got it home yesterday- I tore it down and polished it all up without a single shot out. Made a big difference even though I didnt disassemble the cage. Worked on the accessable parts of the cage without actually taking it apart.

Gonna take it out and break it in Sunday. All factory parts. Filed down the hammer feet a bit- Probably gonna take it down some more for a better SA break with stock hammer.

If I jack that up, new aftermarket hammer isnt too pricey....

Share this post


Link to post
Share on other sites

Jack, where do you file the hammer?

Sent from my iPhone using Tapatalk

You have to be careful when filing the hammer hooks. It may make the SA break nicer but you will probably reduce the surface hardness of that area if you take off too much..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...