Jump to content
Brian Enos's Forums... Maku mozo!
Sign in to follow this  
mioduz

Ejection problems in sti open gun

Recommended Posts

Im having an issue that is happening more and more often. History: i got this pistol 2 years ago and for over a year it ran flawlessly with 38 super and super comp brass intermixed. The malfunctions started maybe once per match and increased in repetitiveness. I think im to the point that i can not make it through two big sticks without a failure.

Now as to the issue. Brass is not leaving the ejection port completely. When there isnt a failure brass ejects and travels what i would say is an acceptable distance (5-10 ft)

The second picture where the brass is vertical was the last shot in mag for what that is worth.

Sent from my DROID RAZR using Tapatalk 2

post-30889-135881642157_thumb.jpg

post-30889-135881644368_thumb.jpg

Share this post


Link to post
Share on other sites
Im having an issue that is happening more and more often. History: i got this pistol 2 years ago and for over a year it ran flawlessly with 38 super and super comp brass intermixed. The malfunctions started maybe once per match and increased in repetitiveness. I think im to the point that i can not make it through two big sticks without a failure.

Now as to the issue. Brass is not leaving the ejection port completely. When there isnt a failure brass ejects and travels what i would say is an acceptable distance (5-10 ft)

The second picture where the brass is vertical was the last shot in mag for what that is worth.

Sent from my DROID RAZR using Tapatalk 2

I think its time to change your extractor and ejector

Share this post


Link to post
Share on other sites
Im having an issue that is happening more and more often. History: i got this pistol 2 years ago and for over a year it ran flawlessly with 38 super and super comp brass intermixed. The malfunctions started maybe once per match and increased in repetitiveness. I think im to the point that i can not make it through two big sticks without a failure.

Now as to the issue. Brass is not leaving the ejection port completely. When there isnt a failure brass ejects and travels what i would say is an acceptable distance (5-10 ft)

The second picture where the brass is vertical was the last shot in mag for what that is worth.

Sent from my DROID RAZR using Tapatalk 2

I think its time to change your extractor and ejector

Figured as much. I was thinking about trying an aftec extractor but they are super/super comp specific. Anyone have luck running one with both types of brass

Sent from my DROID RAZR using Tapatalk 2

Share this post


Link to post
Share on other sites
Guest

After changing to a C-more Serendipity I was getting occasional jams like the one in the first picture.

The cases were ejecting low, hitting the bottom of the port, then bouncing up and rebounding off the bottom of the C-more back into the port and jamming. My port wasn't especially large so a shooting buddy lowered the port a little more for me, and then little by little I changed the ejector so it would kick the cases out of the port higher. Ref: http://www.brazoscustom.com/magart/ejection%20perfection.htm

This is bad ju-ju to say aloud, but after tinkering with this a little I haven't had a jam like this in a few thousand rounds now.

Share this post


Link to post
Share on other sites

Check the extractor tension first. Do this by taking the slide off and slide a round under the extractor. The round should stay there. Install the barrel in the slide with the round in there. Push the barrell up into lock and then come down and pull the barrel out of the slide. The round should stay put. If it falls out, you need more tension. Also, be sure that the extractor tunnel is clean.

Share this post


Link to post
Share on other sites
Check the extractor tension first. Do this by taking the slide off and slide a round under the extractor. The round should stay there. Install the barrel in the slide with the round in there. Push the barrell up into lock and then come down and pull the barrel out of the slide. The round should stay put. If it falls out, you need more tension. Also, be sure that the extractor tunnel is clean.

Thanks i did that and i will try to get to the range to test out before the next match

Sent from my DROID RAZR using Tapatalk 2

Share this post


Link to post
Share on other sites

If it was ejecting in the past with no problems then your ejector is just fine unless it got damaged somehow. Your extractor tension has changed for some reason.

Share this post


Link to post
Share on other sites

Same here man. I saw some "out of the blue" ejection issues for a couple matches that looked just like that. New springs in my AFLAC and they went away. Along with my insurance problems. HA!

Share this post


Link to post
Share on other sites

I had a similar problem in a 9 major open gun I used to have. After checking the extractor and ejector, it ended up being a weak recoil spring. I'd recommend replacing the recoil spring if the extractor isn't the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...