Jump to content
Brian Enos's Forums... Maku mozo!

Hammer falls to half-cock when loading from slide lock


RAZZ

Recommended Posts

I have a strange problem I'm hoping someone could help with. I have a SA TRP that I put a Brazos pre-fit hammer and sear in. The trigger pull is great, all the safety checks are good, but when I load (with dummy rounds) from slide lock by hitting the slide release, the hammer falls to half-cock. If I let the slide slam closed on an empty chamber (like you're not supposed to do), it does not fall to half cock. If I load by racking a round from the slide-forward position, the hammer stays back as it should.

The gun still has the factory disconnector, and an aftermarket flat trigger (EGW). I can't quite wrap my brain around why it would do it while chambering a round, but not on an empty chamber. I'm going to try a factory trigger, just in case, but the disco. does not seem like it should be an issue--stock or not.

Any suggestions (short of calling Bob)?

Link to comment
Share on other sites

Well, I swapped out the disconnector with an STI one I had, and it seemed to have solved the problem (or at least masked it for now). We'll see after a trip to the range.

If I have any more problems, I'll try bending the spring.

Thanks

Edited by RAZZ
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...