Jump to content
Brian Enos's Forums... Maku mozo!
Sign in to follow this  
ak47traxx

Para P16 Mag issues

Recommended Posts

I just replaced my springs and followers in my P16 mags and not the last round doesn't feed right. It hangs up half way, half in the mag, half on the ramp. The slide locks back too, if I hit the slide release, then it feeds in with no problem.

Any ideas how can I fix this problem?

Thanks,

Bruce

Share this post


Link to post
Share on other sites

Having the same problem...hope someone chimes in with a possible answer. I am loading to 1.2 OAL and it is 100% otherwise but sort of defeats the 21 reloadable thing.

Richard

Share this post


Link to post
Share on other sites

My OAL is a little under that. Around 1.18 best I recall. I've tried both lead and jacketed bullets, so I don't think it's ammo related.

Share this post


Link to post
Share on other sites

Did the gun run fine before the magazines were rebuilt?

Is the slide locking back? If so then the followers are engaging your slide stop too soon, remove material from the ledge that engages the slide stop. your feed angle may be different on the new followers as well, if so, you can reprofile without too much trouble.

Hope this helps, can't really offer more without looking at the gun/mags in hand.

Ken

Share this post


Link to post
Share on other sites

Since your bullet lengths are not too long and it is happening on several types of bullets, my thought is that the slide lock is being engaged by the follower by itself; as opposed to being bumped by the bullets or your hand. See if the new follower has a higher slide lock ledge than previously. Also possible that the new spring has a stronger tilt upward on the front of the follower thus engaging slide lock earlier than necessary. Adjust as necessary so that it does not engage so early.

Share this post


Link to post
Share on other sites

Some of us at work got a smoking deal on some P-16s. They all had the same problem. I took a little of the top of the "ledge" that engages the slide stop and no more problems. I put a small detent on the slidestop itself as well for a little insurance. I think my buddy has put a couple thousand through it since and no problems.

Share this post


Link to post
Share on other sites

Thanks for the tips everyone, now if 5 o'clock would get here I could go home and try this :cheers:

Share this post


Link to post
Share on other sites

The only problems I've ever had with my P16 involved the slide lock.

There are 2 problems.

1) The follower hitting the slide stop and changing the feed angle.

Either remove a bit of the follower that engages the slide stop or remove some material from the slide stop where it engages the follower. I modified all of my mags, but I still had a few jams. It wasn't until I reshaped the slide stop that it became 100%

2)The slide stop actually got pushed out a bit and locked the slide up pretty darn tight.

So adding a larger detent for the plunger to mate with solved the problem. No more death jams.

Share this post


Link to post
Share on other sites

I just sent three new mags back to Para (p1640) because the followers were sticking. My para is 8 years old, never jams, the original mag runs great, but I had trouble with the new ones right off the bat.

Share this post


Link to post
Share on other sites

I just built my new mags, Para mag tubes, dawson spring, baseplate and +1 followers and I experienced this issue yesterday (first time shooting gun). When you state take a little off the ledge on the follower that engages the slide stop, I just want to confirm this fixes the issue by allowing the slide to lock back once empty still right? A friend said he did this on his STI to make his slide not lock back and I dont want that to happen.

Share this post


Link to post
Share on other sites

How about last rnd standing straight up slide not locked back?

dawson pads stock spring.

the pad package says to use extended springs.

web sight says it can use stock springs.

I orderd the extended springs,

am I going in the right direction ?

Share this post


Link to post
Share on other sites

I have users stock mag springs and ISMI 140mm para mag springs with no issues. I also run DP mag extensions and factory follower.

Is the round standing up in the mag or in between the slide and barrel?

Share this post


Link to post
Share on other sites

between slide and barrel

the rim is at the very end of the feed lips, still in the mag and the nose at the top of the chamber.

only the last rnd, and not all the time.

Share this post


Link to post
Share on other sites

Anyone have pics or diagrams? I would like to see what I should be doing before I start removing that which I can not put back. Thanks for any info. BTW Happy Turkey day! :cheers:

Share this post


Link to post
Share on other sites

I took a couple coils off the spring and took some fine steel wool to the followers. Seems to have fixed the problem. Still testing them but so far so good.

Share this post


Link to post
Share on other sites

Where can one get stock para followers for a P16?

Sent from my iPhone using Tapatalk

Try Brownells for stock Para followers. Dawson Precision also has modified Para followers.

Edited by Roy Hess

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...