Jump to content
Brian Enos's Forums... Maku mozo!

CZ-USA Model 712 Utility


Recommended Posts

  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Went to the range today and tested several different low recoil slugs @ 50 yards with a mod. Briley extended choke and found the Federal blue low recoil slugs shot the best. Wouldn't cycle the Fiocchi 1100 fps or 1300fps 1 oz slugs. Shot the Brennecke OK but was best with the Federal.

Also changed the way he was lining up the sights. Not used to a vent rib and large fiber optic up front. Worked on using and squaring up the vent rib more to line up the target with the front sight. Much more consistent groups.

gerritm

Link to post
Share on other sites

Shot another 50 this afternoon and had several double feeds. I was shooting poppers in a row and working on speed so may have well been pulling the trigger before it had got back in battery. Anyone had this malfunction in a 712 and do you think I have the right diagnosis? Have the plug out but no extension yet. Seemed to no double feed when I slowed down a bit. Thanks.

Link to post
Share on other sites

Shot another 50 this afternoon and had several double feeds. I was shooting poppers in a row and working on speed so may have well been pulling the trigger before it had got back in battery. Anyone had this malfunction in a 712 and do you think I have the right diagnosis? Have the plug out but no extension yet. Seemed to no double feed when I slowed down a bit. Thanks.

That doesn't sound good. When I first got mine, I loaded 8+1 and pulled the trigger as fast as I could. I did it with several types of ammo. Not much left of the IPSC target I was aiming at, but no double feeds. That's why I get frustrated when I have a hiccup at a match because it's never done it to me in practice/testing. I've done it a couple times since and no problems. Others at the range are always impressed.

Link to post
Share on other sites

Yeah, me too when it was new. Now about 200 rounds, little less. I also have a ton of what looks like plastic shavings when I pulled the handguard off. I they are thin and look like the polymer furniture. This has happened after every shooting (3Xs). The spring is rough and looked like it might have been contacting the bottom of the handguard a bit. I lubed everything up with CLP the last trip out including the inside of the handguard. I can't imagine whatever is rubbing would be related to the double feed problem.

Link to post
Share on other sites

Yeah, me too when it was new. Now about 200 rounds, little less. I also have a ton of what looks like plastic shavings when I pulled the handguard off. I they are thin and look like the polymer furniture. This has happened after every shooting (3Xs). The spring is rough and looked like it might have been contacting the bottom of the handguard a bit. I lubed everything up with CLP the last trip out including the inside of the handguard. I can't imagine whatever is rubbing would be related to the double feed problem.

You don't have a photo of the double feed do you? If not, could you recreate it and take a photo?

Link to post
Share on other sites

What ammo? Double feed could be cause it is not fully ejecting the first round and feeding the next. Light loads do not work in this shotgun. My son has shot several hundred rounds with no feeding issues. We have seen some plastic shavings from the rounds. Guessing it is from everything breaking in. Chamber is tight.

Link to post
Share on other sites

These malfunctions started AFTER 125 rounds of Fed 3 dram 1 1/8. It is intermittent but happens almost ever magazine full (5) rounds now. I wonder if it is related to the shaving. I think it is from the handguard because they are black. Shooting red Federals and they have been working fine when I had good lube. Tried Eezox to see if it would run dry. Did fine for about 40 rounds then started intermittent failure to eject empty. FP10 keeps it wet much longer, of course. The Double feed. It is fairly straightforward. Empty ejected, live round under the extractor nose tipped down about 30 degrees. Second round has left the magazine and is between 1/2 and 2/3 of the way out of the magazine. The nose of the round on top is pressing down on the round coming out of the magazine and bolt is forward maybe 1/4 of the way to full battery. Maybe less. In an AR it would be drop the mag and shake shells out. This jam is a bear to clear. Sure not gonna be fun under the clock. Thanks a bunch for trying to help me figure this out. I will try to shoot later today and will take pics. I sure hope I get it fixed and have no pics to take.

Edited by horseman
Link to post
Share on other sites

horseman,

For what it's worth I had those same plastic shavings but no malfunctions of any kind. I realized the shavings made the forend choppy underneath in places .I took some 150 grit sand paper and smoothed the choppiness out. That may be an idea to try that and retest. Then do post a pick if you can catch the doublefeed.

Link to post
Share on other sites

So took it apart and took the bolt release shell stop out to see if there were shavings behind it hinking stuff up. No shavings there but did notice that the lifter is touching the back side of the shell stop/release button enough to prevent it from dropping when pushed up by my finger. For those with a 712 does yours touch and or hang up. I have the bolt out in the picture but do not think it would matter. Thanks.

th_712pic2012.jpg

Link to post
Share on other sites
  • 2 weeks later...

Anybody ever find a factory fit butt pad?

Only thing I have found is that ATI replacement stock. It has a thicker pad built in. CZ USA sells it as an accessory as well as the factory-installed stock on a newly released 712 model.

I was measuring the stock end against Limbsaver templates a couple of days ago. I think a slip on will be the way to go when considering their product line.

Link to post
Share on other sites

Thanks, sshultz. The CZ smith said the lifter was suppose to ride on that mechanism. Getting a bit frustrated. Pulled the bolt release button and checked for shavings behind it. No go. I've been exchanging emails with the CZ gunsmith who has been very helpful. I sanded then later dremeled the inside of the guard in a effort to do away with the shavings. No go. I polished the rough spring with flitz and the magazine tube. No change. I am surprised after 350 rounds I am still getting as many shavings after shooting--and they get everywhere. The last time they was one chunk in the magazine cap. So last week took it for a 100 round sporting clays course. I did make 2 changes when I should have made 1. I put back in the stock bolt handle on the outside chance it might be causing the problem and I changed ammo. The ammo was because Wally World was out of the 1 1/8 oz Federals so I shot the 1 oz instead. The good news is I did not experience any double feeds in the 80 rounds I shot. The bad news is on round 5 and two or three more times I had a failure to feed where the bolt locked back and a round was laying on the lifter. At about 50 rounds I started having frequent failure to eject with the spent round hanging in the ejection port. I oiled the chamber and bolt area to no effect and put it in the truck and pulled out the 1100 to finish. The CZ gunsmith has sent me a new bolt release mechanism which I put in yesterday. I plan to run another 100 rounds through it as soon as the blizzard lets up. If I have problems it is going back to CZ 1 time. The gosh awful trigger is much better and it shoots and patterns very well. Very handy and light but it's gonna have to run.

Edited by horseman
Link to post
Share on other sites

If it was Winchester bulk good luck getting it to run reliably don't know of anyone that can get that stuff to run well! the 1oz 3 dram stuff.Federal bulk 3 1/4 dram 1oz runs like a champ thought.

My lifter rides the whatever it's called doo hicky but I've had no issues, the shavings I have no idea! got any pictures you can post? Later,

Kirk

Link to post
Share on other sites

Is that coming from your forearm? wonder if the piston is shaving the plastic forearm? one thing about it if that is the culpirit it'll soon stop LOL. Do you have a pic of the inside of the forearm?

A buddy had a mess of Remington given to him and he tried to run it in his Benelli, it did fine 1 at a time! hard to go wrong with the Federal 3 1/4 dram loads they just run good for a cheap shotshell. Later,

Kirk

Link to post
Share on other sites

Yes, inside of forearm. A pic of the inside of the forearm would show you where I have been sanding, then dremeling and then dremeling some more all to zero apparent affect. The pic is after 350 rounds. I really thought it was the spring but after I worked it over with Flitz it is pretty smooth. I put in a new bolt release magazine tube retainer mechanism and shot it today. Ran 25 rounds through pretty much as fast as could and man this thing can run fast. I got to have my wife video me. I think I can get 4 empties in the air at the same time. I noticed before I put it in that the spring holding the magazine block in place was quite a bit stronger. Loading the mag tube after installation-- big difference. When this thing runs it is awesome.

Link to post
Share on other sites

Dude it took me awhile to get mine to the point it ran awesome but we were playing trying to figure out what needed to be done so we would do one thing run it awhile then do something else and run awhile. Yes that little shotgun is fast only thing I know that is faster is my Franchi but for the most part a lot of the CZ is Franchi with some Benelli thrown in.

You'll get there and that little sucker will make you smile when you see the $1500 shotguns choke or hick-up and your cheap beater is running. Later,

Kirk

Link to post
Share on other sites
  • 3 weeks later...

I shot my 1st 3 gun match with the CZ today. All went well till the last stage with 2 clay birds left when the gun quit. Took the gun home tore it apart and found the hammer broke. Not of to a good start. I'll CZ on monday.

Schultz

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...