Jump to content
Brian Enos's Forums... Maku mozo!

Search the Community

Showing results for tags 'sr1911'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • FAQs & News
    • Visitors & New Member Info
  • BEginners
    • Introduce Yourself
    • Miscellaneous BEginners
  • Shooting
    • Handgun Techniques
    • Stage Comments or Questions
    • Training Techniques
    • Tips for Improvement
    • Skills
    • Mental Conditioning
    • Zen
    • Little things I've Noticed
    • Match Screw-ups
  • Technical
    • Factory Pistols
    • 1911-style Pistols
    • Open Pistols
    • Gear & Accessories
    • General Reloading
    • Gun Springs
    • General Gunsmithing
  • Shooting Sports & Travel
    • Travel, Locations, Ranges, etc.
    • Match Announcements - Pistol Only - USPSA, IPSC & Misc.
    • USPSA/IPSC Shooting
    • USPSA/IPSC Rules
    • Revolver Forum
    • IDPA Shooting
    • Other Shooting Sports
    • USPSA Classifier Scores
    • Clays
  • Match Management
    • Pre-match
    • Operations
    • General Match Issues
  • Multi-Gun
  • Miscellaneous

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Real Name


Spam Bot Control

Found 2 results

  1. I have a Ruger SR1911 that I absolutely love and I have about 1800-2000 rounds through her so far. On my last couple of range trips it has been chewing up the brass as below and the recoil and sound seem off. I looked at with some of the staff at the range it looks like it is perhaps firing slightly out of battery. I am shooting my own reloads, 230 Gr. Berry RN with 7.1 of Power Pistol at 1.260" with CCI primers. This is a load I use regularly with no issues. I had the same thing happen 2 range trips in a row on 2 different batches of the same load, loaded on my Dillon 550 and all rounds are case gaged before firing. The weapon is cleaned and relubed after each range trip. After this happened on the first magazine of the trip I stopped firing that batch on that weapon. I then tried the exact same batch of loads on the Range's rental gun, the exact same weapon, a Ruger SR1911. The rental SR1911 fired the remaining 93 rounds without any issues. I tried my magazines in the rental SR1911 with my loads and they functioned flawlessly. The first time my SR1911 was cleaned with Slip 2000 725 and lubed per manufacturer's recommendations with Slip 2000 EWL the second range trip I completely detailed stripped the weapon, found no signs of any obvious damaged cleaned to bare metal and lubed with Militec to Ruger recommendations. Please see the pictures and let me know what you think is going on with my SR1911. Thank-you for the help everyone. Joe
  2. Can someone suggest the best and easiest grip safety to install on a SR 1911 Government model? I'm replacing all factory parts with Stainless Steel ones but I'm having a difficult time finding the right grip safety. Most of the parts already replaced have required a little bit of fitting with no problem. However, the grip safety has been my nemesis. Any suggestions? Thanks.
×
×
  • Create New...