Jump to content
Brian Enos's Forums... Maku mozo!

Search the Community

Showing results for tags 'marks'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • FAQs & News
    • Visitors & New Member Info
  • BEginners
    • Introduce Yourself
    • Miscellaneous BEginners
  • Shooting
    • Handgun Techniques
    • Stage Comments or Questions
    • Training Techniques
    • Tips for Improvement
    • Skills
    • Mental Conditioning
    • Zen
    • Little things I've Noticed
    • Match Screw-ups
  • Technical
    • Factory Pistols
    • 1911-style Pistols
    • Open Pistols
    • Gear & Accessories
    • General Reloading
    • Gun Springs
    • General Gunsmithing
  • Shooting Sports & Travel
    • Travel, Locations, Ranges, etc.
    • Match Announcements - Pistol Only - USPSA, IPSC & Misc.
    • USPSA/IPSC Shooting
    • USPSA/IPSC Rules
    • Revolver Forum
    • IDPA Shooting
    • Other Shooting Sports
    • USPSA Classifier Scores
    • Clays
  • Match Management
    • Pre-match
    • Operations
    • General Match Issues
  • Multi-Gun
  • Miscellaneous

Calendars

  • Community Calendar

Product Groups

  • Books
  • Slide-Glide

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Real Name


Spam Bot Control

Found 1 result

  1. I have an STI TruBor that I shoot in Open... I have gone through many jamming problems, including sending my gun back to STI for a replacement barrel and slide... After getting it back from STI, I added an Aftec extractor... My jamming problems are greatly improved, yet I still do get an occasional jam where multiple bullets collide in the chamber. I have noticed that the flat area on the front of my barrel ramp has what looks like marks from the front of a bullet. I'm wondering if this could be causing my jamming problem? I've never seen this kind of problem in either my Limited or Single Stack guns, so I'm posting this in the Open forum... Does anyone know what causes these marks?
×
×
  • Create New...