Jump to content
Brian Enos's Forums... Maku mozo!

Angelr15

Members
  • Content Count

    15
  • Joined

  • Last visited

About Angelr15

  • Rank
    Looks for Range
  • Birthday 11/14/1989

Profile Information

  • Gender
    Male
  • Location
    PNW
  • Real Name
    Garrett Creal

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I just started loading with hs6 as well and have noticed the same thing.
  2. I switched bullets from a berrys flat point to a berrys rounded shoulder. I also changed the OAL to 1.135 from 1.125 as this is the recommended COAL for this bullet and it feeds great. I played up and down with slowly manipulating the slide to load the rounds with no recoil spring and found this to be smooth and consistent.
  3. Happy to report that I changed bullet profile to rounded shoulder and adjusted OAL and it is running great so far.
  4. Happy to report that I changed bullet profile to rounded shoulder and adjusted OAL and it is running great so far.
  5. Oh goodness at least I'm not alone lol I am going to try a rounded shoulder bullet too to see if that helps. Not sure how to go about polishing the mentioned items... dremel and compound and how much and where lol
  6. I am going to try a rounded should bullet next to see if that clears up the issue. I tried 3 diffrent magazines to verify it wasnt that. All three used have worked well. I was running a heavier recoil spring and smaller previously but I had never shot this load or bullet before. I will try cycling the factory ammo I was using successfully before to narrow it down to a ammo issue...
  7. Thanks for the tips! I'll give that a whirl and see what cycles better and go from there. I also have a rounded shoulder bullet profile that I can try to see if that helps...
  8. Furrly the fact that it does this when manually cycling the slide or sending the slide home with the slide release leads me to think it isnt charge weight related.
  9. I have not chronograph the round yet. The load is close to the book max load and should easily make power factor. Book has this load making 175PF so even if it comes in low it should still be over 165... Also this happens when manually cycling the slide or sending it home with the slide release as well so it isnt charge related.
  10. I did and they plunk in just fine... just wont feed from the magazine consistently...
  11. I have built a new toy glock for shooting open division uspsa out of a glock 22. Gun has shot well with factory ammo but I just switched out to a large 4 port Carver custom compensator so I started loading appropriate ammo for the compensator. I just loaded up my first batch of 40 s&w ammo. I am new to reloading pistol ammo but have reloaded for my rifles for several years. I loaded mixed brass with the following load All brass measured, cleaned, lubed, sized/deprimed, swaged, cleaned, primed, belled, charged, seated/lightcrimped. Check cycling them in the gun and had no setback. Federal small pistol magnum primer 8.5 grains of Hodgdon HS6 Berrys bullets 155 grain fp Loaded to 1.125 I had no pressure signs and the load shot well through my gun but it had about 30 failure to feeds out of 100 rounds this morning. Not sure where to start for resolving the issue. Longer OAL maybe? Gun has recommended 15lb recoil spring from Carver custom but issues happens both why shooting and manually cycling. Here are a few pictures of the issue and the round once cleared as well as the barrel feed ramp. Any help is appreciated !
  12. I did change the recoil spring to the 15lb spring as recommended by Carver custom for this comp. The brass only has this partial ring on the rounds that fail to feed. Did not have this issue before with factory ammo so none of the brass prior has this mark. Failure happens when simply manually cycling the slide without firing so I am guessing it is more ammo related than compensator related since this is the first time I have loaded 40 s&w and first time around with this bullets.
  13. It seams to be clearing the breach face. This happened both while manually cycling the slide by hand as well as while firing. http://
  14. I have built a new toy glock for shooting open division uspsa out of a glock 22. Gun has shot well with factory ammo but I just switched out to a large 4 port Carver custom compensator so I started loading appropriate ammo for the compensator. I just loaded up my first batch of 40 s&w ammo. I am new to reloading pistol ammo but have reloaded for my rifles for several years. I loaded mixed brass with the following load All brass measured, cleaned, lubed, sized/deprimed, swaged, cleaned, primed, belled, charged, seated/lightcrimped. Check cycling them in the gun and had no setback. Federal small pistol magnum primer 8.5 grains of Hodgdon HS6 Berrys bullets 155 grain fp Loaded to 1.125 I had no pressure signs and the load shot well through my gun but it had about 30 failure to feeds out of 100 rounds this morning. Not sure where to start for resolving the issue. Longer OAL maybe? Gun has recommended 15lb recoil spring from Carver custom but issues happens both why shooting and manually cycling. Here are a few pictures of the issue and the round once cleared as well as the barrel feed ramp. Any help is appreciated !
×
×
  • Create New...