Jump to content
Brian Enos's Forums... Maku mozo!

TGibe

Classifieds
  • Content Count

    338
  • Joined

  • Last visited

About TGibe

  • Rank
    Sees Sights

Contact Methods

  • Website URL
    http://www.youtube.com/user/TGibe
  • ICQ
    0

Profile Information

  • Gender
    Male
  • Location
    Auburn, WA
  • Real Name
    Allen Range

Recent Profile Visitors

925 profile views
  1. Looks great! Do most use simple green or something specifically for gun part cleaning like the Lyman stuff?
  2. Do you ever have issues with loosing zero on your optic? I am new to MPX and recently cleaned tappet & gas plug (after 500 rounds) and zero was fine, but I'm wondering if I need to check zero every single time...? Thx, Allen
  3. Did you have to do anything special to get 49 rounds in? Did you use the factory spring or one from TF. I can barely get 44 rounds in using the spring provided by TF. Currently trying to load them up as far as I can, leaving for a couple of days and then unload reload. After 2 cycles I was able to go from 43 to 44. Thx
  4. UPDATE: I'm done with the Guard. I bought an MPX and am moving on - it seems to be running fine out of the box with a mixture of PFs from 132 to 155 and OALs from 1.100" to 1.135". no problems with any of my reloads. I was finally able to get out and do some testing with another shooters mags and ammo. For some reason my ammo wouldn't feed on full mags in either gun and his ammo would feed fine on full mags in both guns and both mags. He was running the red bullets and I am running Montana golds. OAL is pretty much the same. So while I do feel my ammo is the problem I have just lost confidence in the gun - at least for now. I was able to get it to run reliably with less than 36 rounds loaded. Any more than that and it has problems. So I will probably sell it and let someone else fiddle with the loads. I really like the ease of cleaning vs the MPX and the recoil. Bottom line: The problem appears to be my reloads, but I have tried PFs from 132 to 155 and OALs from 1.100" to 1.135". I'm thinking it must be the bullet profile or something.
  5. Thx. I'm not messing with my existing mags any more as they work 100% in my blowback gun - I've literally never had a problem with them, not once. So I don't think it is the mags, but I will go through the process of using my buddies guard with my mag and my mags in his guard to see what happens. If my mags run fine in his Guard then I know 100% its the gun...
  6. After I got it back it still had the same problem. Sent in a slow mo video to CMMG and they thought the bolt was moving too fast so I installed the heaviest weight from their tuning kit with the same problem. I'm still not able to run fully loaded 40 round mags. Been too busy with a new job to meet a friend at the range to swap mags and parts to see what the real issue is. CMMG is trying to work with me, but my use case (USPSA competitive shooter) probably isn't in their roadmap. The CMMG people I talk to are great and they listen and try to help, but the problem is that I ordered the gun for competition last November and still have yet to be able to use it due to reliability issues. Hopefully I can do some testing with a friend next week, but if I can't get a resolution after that I'm going to buy a Sig MPX as I need something to run that will have less recoil than my blowback gun.
  7. Yup. Really trying to find out why the 41 round mags work 100% (not 99.99999% - I've actually NEVER had a failure) in my $600 PSA gun, but not in the more expensive CMMG. I love competing and can't be competitive if I have to reload during a stage and all other competitors don't have to. I chose this gun because I didn't want to go the Sig MPX route. Right now, I'm wishing I had. LOL Seriously though, I do appreciate you taking the time to comment. Any frustration you notice in my reply isn't directed at anyone on this forum (especially you), because everyone is super helpful and supportive as I work through this. It's just that I ordered this gun last November and have sent it back twice for two other problems (which have been fixed) and now I'm facing a third problem... Right now it's a paperweight to me because I only plan to shoot it in competition... LOL - definitely a first world problem.
  8. I’m still having fail to feed on fully loaded 41 round mags. Tried all weights without any change. Tried different power factor loads, OAL, etc. Have sent it back twice now... once mag is downloaded to around 34-35 rounds runs fine. I have a friend with a guard guard and now I need to meet up with him and swap mags, etc to see if it’s mags or the gun.
  9. I don’t have hearing aids yet, but I will need them at some point. I love my sordin supreme muffs, but don’t love using them with long guns. I have molded plugs and like shooting with them but can’t hear Range commands well with them in. So I tend the partially remove one and often forget the replug which is really bad. I have tried non molded electronics (soundgear and walkers) but they just don’t seal well in my ears. So I’m biting the bullet and spending the $1,500 on custom fits - likely the pro ears pro fit line.
  10. Quick Update: Complete rifle shipped back to CMMG to see if they can figure out what's going on. Left my hyperfire trigger and ambi safety installed in the off chance that has something to do with it (but I doubt it). Anyway, super nice folks to deal with, but I hope this gets corrected once and for all this time. Fingers crossed...
  11. He didn't go into details and I didn't press. I will post the results. It's been a long journey for me, but I hold out hope for a good resolution.
  12. Called CMMG and my OAL should be good. Said pretty much if it fits in a glock mag then the guard should eat it up. Sent them the pic and they said this issue "may" be similar to one they discovered and are working on. It's really nice to be able to talk with folks that are willing to listen to someone who wants to run a gun in competition and doesn't just give you the "run it stock with factory ammo" line. Cheers, Allen
  13. Thanks Bart. What OAL and bullet are you running? 33 rounds and below function fine, but I need more testing time to be sure. 37ish and above rounds fail consistently as shown above (could be resistance or bullet angle under spring pressure). Even releasing locked bolt on a full 40 round mag is inconsistent. Will try loading some dummy rounds for bolt locked release testing at home. Also will take a box of factory 9mm to test in fully loaded mags.
  14. Thx. Yes - real glock mags that run perfectly in my blowback PCC. Would rather fix the problem with ammo or the gun than modify working mags...
×
×
  • Create New...