Jump to content
Brian Enos's Forums... Maku mozo!
Shooter94

STI Trubor malfunctions

Recommended Posts

Posted (edited)

I have had an STI Trubor in 9mm major for about 9 months and had nothing but problems for the first 7 but finnaly got some help and have had it running pretty good for a while but this Sunday I was shooting a local USPSA and was doing really good and had a failure to feed and got frustrated and by then I totally flusted and ruined a good day and it also did it on the next stage and after that it ran fine the rest of the day any ideas what would cause this? 

 

Gun set up. Side mounted cmore with a 9lb recoil spring and an afftec extractor running mbx 170mm mags. Ammo is a 124gr hornaday fmj with 6.7 grains of autocomp with an overall length of 1.165 and a cci primer.

 

Ps gun ran perfect the weekend before at another USPSA

Edited by Shooter94

Share this post


Link to post
Share on other sites
Posted (edited)

Feeding issues are most often tracked down to dirty gun, light recoil spring, mag, mag catch, loose screws, or ammo.  Dirty gun is easy.  You are definitely not too light of a recoil spring.  Is your ammo consistent?  Time to figure out if it's one mag or all.  Check grip screws and make sure they are all tight.

Edited by theWacoKid

Share this post


Link to post
Share on other sites

The gun gets cleaned before every match and ammo is checked with a chamber gauge and is closely monitored when being loaded and brass is sorted by head stamp I only use Winchester.

Share this post


Link to post
Share on other sites

What does your ammo chrono at? 6.7 seems a bit on the light side. I use 7.0 AC with a 8# spring (and no aftec extractor) for 174 PF.(1400 fps with a 124gr bullet) I can't remember the last malfunction. It was probably in the break in period up to 1000 rounds. I also use MBX mags. Make sure you tune the follower, feed lips, and springs according to their videos.

Share this post


Link to post
Share on other sites

Sounds like a mag issue are they polished on the inside if so before every match I pull mine apart clean and wax the inside solved alot of my feeding issues especially with the 170s

Share this post


Link to post
Share on other sites

I shot it over the chrono at our gun club and it made 172pf. Where do you find the video?

Share this post


Link to post
Share on other sites
44 minutes ago, Shooter94 said:

Where do you find the video?

 

He may be referring to the video that Atlas Gunworks did on mag tuning.

Share this post


Link to post
Share on other sites
7 hours ago, tyler2you said:

 

He may be referring to the video that Atlas Gunworks did on mag tuning.

Yes, that was it, thanks.

Share this post


Link to post
Share on other sites

Thanks guys my mags where way out of spec  and I fixed them now off to the range to test.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×