ChiefG

Classified
  • Content count

    89
  • Joined

  • Last visited

About ChiefG

  • Rank
    Finally read the FAQs

Profile Information

  • Gender
    Male
  • Location
    Oahu, Hawaii
  1. Mine also dropped in and works without any mods in my S3. Going live fire testing today. I was concerned about the undersized pin being too loose but after reading replies from ARy and johnbu, am not worried about it anymore. ETA Titan hammer, Extreme sear in factory housing, EGD light hammer n firing pin spring, factory plunger with 2 coils cut off, factory trigger bar, polished all internals
  2. Sorry , yes I meant the "over travel screw" on my last reply...
  3. I did observed that the trigger bar was not going high as it can go and not catching something, but not sure if it's the disco or the bottom part of the sear leg. Response to the replies above: 1. pre -travel screw is not too far out, one of the first thing I checked. 2. yes there is a pre=travel screw on Stock 3's 3. I did re-installed the original plunger with the original spring but did not help. Crossed this off the list to check. 4. will check again for any burrs and I only polished the disco with Flitz , not too much. Beer Baron and Eng. Eli; With your replies and suggestions, I am now armed with better info and understanding of how a Tanfoglio trigger action works and hopefully can solve this issue. Thank you so much for your help.... I will post an update as soon as I get the chance to work on the gun again.
  4. Thank you for the suggestion, I will look into it. I was planning on swapping trigger bar. I'm not charging anything, I'm actually trying to help him out. One shooter was selling his stock 3 for over 2k with the upgrade and he was going to buy it but I told him it's too much. Just buy a stock,factory, one and I offered to do this upgrade for him. Don't assume anything....
  5. Finished working on a second S3, when dry firing in double action it skips once in about 20+ pull. What I mean by skip is its not activating the hammer. When the slide is off and I pull the trigger it will not activate the hammer at all in double action. Works on single action, when you thumb down the hammer first and then pull the trigger. (I hope this makes sense). Work done: Installed Titan hammer with EGD light hammer spring Installed two wing Tanfoglio disconnector Installed one piece EGDExtreme sear fitted to safety Cut 2 coil plunger spring Polished all trigger components, conservatively. Retained stock sear spring and TRS As mentioned this is my 2nd trigger job on an S3. The first one went very well and I used the same components , did exactly the same work and never had this problem. The 2nd gun is brand new which was only test fired from the factory. I even swapped the sear group and plunger from the first one . Still same problem. But I stop short on swapping the trigger bar. Which just occurred to me when I was typing this. I returned the gun to the owner and advised him to test fire the gun and will work on it again this weekend. I'm hoping someone in this forum with the expertise can help me? Any suggestions will be greatly appreciated. Thank you....
  6. Good idea, will try this. Thank you.
  7. I got mine from Shooter's Connection
  8. Any tricks how to install these? Grip holes doesn't align with the frame hole. I'm having difficulty installing the grip screws. I don't want to strip the thread on the frame so I decided to stop and ask here first. I followed Instructions on LRA site but still couldn't do it. Any inputs will be greatly appreciated! ETA: Important note for installation: The Xtreme grips have been produced to tight tolerances to ensure the fit to the frame is tight with no movement. When installing the grip screw follow these instructions. Insert the grip and apply pressure on the grip on and upward 45 degree angle to pressure the grip into the frame. Insert the screw into the grip and line it up with the frame at a 90 degree angle before attempting to screw it in. The fit will be very snug against the grips to minimize movement. Only when the screw is going straight in and NOT on an angle slowly install the screw until it is flush with the grips. Do not attempt to install the screw if it is not at the correct 90 degree angle otherwise cross threading may occur.
  9. Remember the bushing is retained by front sight pin. yes, still need to use the pin together with set screw to keep it from moving...thank you...
  10. I replaced mine with; DP .175 tall, .100 width, FO size .060. It's drop-in with no drilling. It has a set screw to hold the sight in place, make sure to use loctite.
  11. can't go wrong with the Blade Tech, been using it for a year now. no problem so far.